EQEmulator Forums

EQEmulator Forums (http://www.eqemulator.org/forums/index.php)
-   General::News (http://www.eqemulator.org/forums/forumdisplay.php?f=594)
-   -   Recent Source and CMAKE Changes - FYI (http://www.eqemulator.org/forums/showthread.php?t=41293)

Akkadius 04-19-2017 04:40 PM

Recent Source and CMAKE Changes - FYI
 
If you're have issues compiling, keep in mind the following information.

- Windows: You need Visual Studio 2015 or later
- Linux: You need GCC 4.8 or later

- You will need to download new dependencies: http://eqemu.github.io/ and add them to your dependencies folder for your respective build type (x86 or x64) (Windows)

Make sure you're running a recent version of CMAKE. Delete Cache, Configure and Generate. You should have no issues building after that point.

The_Beast 04-19-2017 04:56 PM

Ok that explains my other post, but I was wondering, the VS 2015, is there an "exact" version we need to grab ? (like this one I am using is VS 2013 express for win desktop)

Akkadius 04-19-2017 04:57 PM

Quote:

Originally Posted by The_Beast (Post 254315)
Ok that explains my other post, but I was wondering, the VS 2015, is there an "exact" version we need to grab ? (like this one I am using is VS 2013 express for win desktop)

No, you can grab VS2017 while you're at it. Community works fine.

https://www.visualstudio.com/vs/whatsnew/

The_Beast 04-19-2017 05:02 PM

Oh thanks, I just grabbed the 2017 Community install, but one more "pita" question.
With VS 2017 installed, what version in Cmake configure do we select ?

Akkadius 04-19-2017 05:03 PM

Quote:

Originally Posted by The_Beast (Post 254317)
Oh thanks, I just grabbed the 2017 Community install, but one more "pita" question.
With VS 2017 installed, what version in Cmake configure do we select ?

The one that says 2017

http://i.imgur.com/5W4e6V7.png

The_Beast 04-19-2017 05:06 PM

Who'd a thought, lol. Thank you kind Sir :)

demonstar55 04-19-2017 05:11 PM

Just clarify, I do believe we still compile and work fine under 2013, but our official version of support is now 2015+. Which basically means, if we break 2013, too bad :P

GCC in fact does not work sub 4.8.

The_Beast 04-19-2017 06:10 PM

Quote:

Originally Posted by demonstar55 (Post 254320)
Just clarify, I do believe we still compile and work fine under 2013, but our official version of support is now 2015+. Which basically means, if we break 2013, too bad :P

GCC in fact does not work sub 4.8.

I was using cmake 3.3 so I am in the process of upgrading to 3.8 right now, which I need for the 2017 I just installed.
But as per my other post, the cmake 3.3 and vs 2013 wouldn't compile the updated source this morning.

The_Beast 04-19-2017 08:46 PM

Well, everything compiles good with VS 2017 and cmake 3.8 BUT my loginserver is looking for a file libeay32.dll before it will run. Anyone know where I can get one ? :P

ghanja 04-19-2017 09:07 PM

Did you grab the new dependencies? I believe that is part of OpenSSL, though I may be way off.

The_Beast 04-19-2017 09:17 PM

Yes I did. I grabbed the file from openssl, but that didn't work, so now I am installing the whole openssl to see what happens

The_Beast 04-20-2017 02:48 AM

Just an update for problem solved (and how). After installing the VS 2017 Community and Cmake 3.8 (note: need to uninstall old cmake first) then install OpenSSL.
Not sure if these other two steps are something others would have to do, but even though I am running a 64 bit box, I had to use the 32bit(x86) dependencies.
It would not compile with the 64 bit ones. Then when trying to get the loginserver binary to find the libeay32.dll , I had to copy that into the main EQEmu server
folder. I tried pathing it in system variables, but no dice. After installing OpenSSL, that file was in C:\Program Files (x86)\GnuWin32\
Updated source compiles, server runs, no issues. :)

Albator 04-20-2017 04:59 PM

Beast I noticed on your last post you were using x86 visual studio I think it was, did you get x86 VS2017 too?

kokey98 04-21-2017 04:51 PM

Quote:

Originally Posted by The_Beast (Post 254331)
Just an update for problem solved (and how). After installing the VS 2017 Community and Cmake 3.8 (note: need to uninstall old cmake first) then install OpenSSL.
Not sure if these other two steps are something others would have to do, but even though I am running a 64 bit box, I had to use the 32bit(x86) dependencies.
It would not compile with the 64 bit ones. Then when trying to get the loginserver binary to find the libeay32.dll , I had to copy that into the main EQEmu server
folder. I tried pathing it in system variables, but no dice. After installing OpenSSL, that file was in C:\Program Files (x86)\GnuWin32\
Updated source compiles, server runs, no issues. :)

i did the exact same thngs -- relatively speaking. i had x64 ssl, had to install 32bit version (heh, hope that's not an issue, hasn't been so far.)

also copied same file over to server directory when i saw the error.

but, i couldn't compile in x64 (didn't auto-fill all the directories and such) because i hve the 5.12perl from akka's installer, and i think you need the 5.14 for x64? so, i guess i can ~nearly verify exact same thing. i used all the installs from the akka installer, so, i didn't re-install anything excewpt a 32bit openssl.

i read that 32bit won't make a difference for an eqemu server, so i didn't worry aobut it. is that different now? does a 64bit compiled server function better in any way? i have something else dependent on perl, and i don't want to have to tweak paths/settings whatever, lol... so 32 was path of least resistance (from what i read 2 perl installs is clearly a bad thing.)

edit: i may have typed "x86" in for machine... but that may have been when i wsa having problems getting cmake to populate... i tried a few things and the memories blend a bit at this point a few days later.

kokey98 04-21-2017 04:59 PM

Quote:

Originally Posted by The_Beast (Post 254322)
I was using cmake 3.3 so I am in the process of upgrading to 3.8 right now, which I need for the 2017 I just installed.
But as per my other post, the cmake 3.3 and vs 2013 wouldn't compile the updated source this morning.

i have cmake 3.7 and it worked with 2017.

and, it only populated in cmake with Visual Studio 14 (2015) selected in the dropdown for compiler.

32-bit was fine.. i think i was missing the correct perl for x64... couldn't compile that one, and didn't want to mess with uninstalling / re-installing perl.


All times are GMT -4. The time now is 04:31 PM.

Powered by vBulletin®, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.