EQEmulator Forums

EQEmulator Forums (http://www.eqemulator.org/forums/index.php)
-   Support::Linux Servers (http://www.eqemulator.org/forums/forumdisplay.php?f=588)
-   -   Private Login Server, remote access (http://www.eqemulator.org/forums/showthread.php?t=43057)

lynwood 09-13-2020 11:54 PM

Private Login Server, remote access
 
I know, I know, lets beat this dead horse a few more times. I see question after question asking about it, and nobody really answering the questions. Is it possible at all to allow someone across the internet to connect to my server, and play, using the private login server...??

I have it setup, really nice, or so it seems, and I can connect locally, and it plays fine and dandy, but my buddy, who I set all this up for, cannot login and play. Poor fella is going crazy ever since I told him I was going to try setting it up for him. If anyone has been successful at this, please help.

If its not possible, lets put it out there, and once and for all, I'll quit trying.
I had one setup years ago when it first came out, and the login code was all hush hush, and all that. I thought, at least it sounded like we had gotten past all that BS, and a private login server was finally possible..

Thanks for reading, and I hope someone can help.

Peace,
Lynny

FievelMousey 09-14-2020 01:14 AM

Yes it is possible if you setup everything using private LS.

djeryv 09-14-2020 04:01 AM

It has been a long time since I did this, but I think it was a combination of using your public IP in some spots and your private IP in other spots when dealing with config files. Then you obviously have the firewall ports and port forwarding you need to do. The ports should be an easy one, but the config files always was a trial and error affair for me when I did this.

lynwood 09-14-2020 09:55 AM

Excellent, ok..now I know it works, now to find someone who..
 
Thanks for the replies!

Now, I need replies from those who knew actually know how to set it up.
I've fought and fought..changed IPs around till I'm dizzy..and still...

Error 1017 for my buddy when he tries to connect..
We're both running ROF2 client.

Peace,
Lynny

Thalix 09-14-2020 01:34 PM

Please show us your json files and the port forwarding from your router.

djeryv 09-14-2020 07:27 PM

eqhost.txt for your friend?

hayward6 10-14-2020 04:45 PM

I can have a look at this later, but it's not something you would usually struggle with... If you have someone coming in over the internet anyways, just use the public login server. You're going to have to adjust your friends host file, so just point it where he can get the most use of it.

djeryv 10-14-2020 04:59 PM

It's been a month. I think they figured it out or gave up.

Huppy 10-14-2020 05:56 PM

I use this config all the time, even last week, I logged on from a friend's place. (Just in case anyone else is looking for a fix) NOTE: This config is based on my own preferences. I don't use telnet or web, etc, so those are disabled and I use the old 9000 for world, instead of 9001. But either way, it's important to have that EXTERNAL IP under world block, for private, outside connections, as well as the port forwarding in both your windows/linux firewall and router/modem firewall.

If using Windows 10, there has been known issues of a port being used by something in windows, causing problems for the server ports used. There are several things to consider that may be blocking a port. If your friends make it onto the login/server select screen, that port is open. If they make it to the character select screen, but can't get into world, chances are 9000 or 9001 is blocked somewhere. could also be an antivirus running, or any 3rd party application doing it. Grab a shovel and start digging.

Something else to consider. Those outside clients need to point their eqhost to your external IP, but if you constantly experience dynamic IP changes from your ISP, you would have to keep an eye on it, or use a service like dyndns, etc.

I realize there are pros and cons for using either private or emu public login. Trying to stay private, using the public login, creates more tedium, but I would also CAUTION, using a private login, open to the internet, it is exactly that: Open to the internet!! Something I've done, is first, I let a couple friends log on, with the "auto_create_accounts": true set in login.json. THEN, after they create their accounts, I change that to false (and restart server).

This kind of issue, gets posted randomly, and always buried in these forums, but this is the last time, I'm replying to it, haha. Have fun !!! ;)

Code:


{
    "server" : {
          "chatserver" : {
              "host" : "192.168.0.3",
              "port" : "7778"
          },
          "database" : {
              "db" : "peq",
              "host" : "127.0.0.1",
              "password" : "******",
              "port" : "3306",
              "username" : "******"
          },
          "directories" : {
              "logs" : "logs/",
              "lua_modules" : "lua_modules/",
              "maps" : "maps/",
              "patches" : "./",
              "plugins" : "plugins/",
              "quests" : "quests/",
              "shared_memory" : "shared/"
          },
          "mailserver" : {
              "host" : "192.168.0.3",
              "port" : "7778"
          },
          "qsdatabase" : {
              "db" : "peq",
              "host" : "127.0.0.1",
              "password" : "******",
              "port" : "3306",
              "username" : "******"
          },
          "world" : {
              "address" : "142.165.58.37",                //<---------- MUST BE EXTERNAL IP
              "http" : {
                    "enabled" : "false",
                    "mimefile" : "mime.types",
                    "port" : "9080"
              },
              "key" : "qwertyu6543789zxcvbnmasdfgh",
              "localaddress" : "192.168.0.3",                // <-------- SERVER LAN ADDRESS THAT PORTS ARE FORWARDED TO
              "loginserver1" : {
                    "account" : "******",
                    "host" : "192.168.0.3",
                    "legacy" : "0",
                    "password" : "******",
                    "port" : "5998"
                                },
              "loginserver2" : {
                    "account" : "",
                    "host" : "127.0.0.1",
                    "legacy" : "0",
                    "password" : "",
                    "port" : "5998"
              },
              "longname" : "Server Name",
              "shortname" : "servername",
              "tcp" : {
                    "ip" : "192.168.0.3",
                    "port" : "9000",
                    "telnet" : "disable"
              }
          },
          "zones" : {
              "defaultstatus" : "0",
              "ports" : {
                    "high" : "7500",
                    "low" : "7100"
              }
          }
    }
}



All times are GMT -4. The time now is 04:54 PM.

Powered by vBulletin®, Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.