EQEmulator Forums

EQEmulator Forums (http://www.eqemulator.org/forums/index.php)
-   General::News (http://www.eqemulator.org/forums/forumdisplay.php?f=594)
-   -   Netcode Update (http://www.eqemulator.org/forums/showthread.php?t=41289)

Akkadius 04-18-2017 01:06 PM

Netcode Update
 
All,

Just wanted to make a quick update regarding the latest massive change to the Emulator source. Thanks Mackal/demonstar for making the original post to let users know.

KLS has spent close to a year working on a massive revamp of the EQEmu base netcode. After a recent onslaught of testing and ironing out some of the latest issues, it's been stable on PEQ for several days. It has been merged into the master EQEmu branch as of a few nights ago.

This netcode overhaul includes much cleaner and manageable code, many optimizations, far more robust, leaner (takes far less CPU) and has been needed for a long time.

In the changelog there are a few notable changes that you will need to make in your environment if you choose to make this update.

In your eqemu_config.xml you will need to make some changes. To connect to a Loginserver using older netcode such as the EQEmu Loginserver, you will need to add a 'Legacy' XML tag:

http://i.imgur.com/rSiNOd0.png

If you use the telnet server embedded in the World server, you will need to make the following adjustments to your world config:

http://i.imgur.com/SgOoNWx.png

These defaults have also been changed in the 'Akka Installer', you can see them here:

https://github.com/Akkadius/EQEmuIns...c19bd7124ca738

For more information, see the changelog:

https://raw.githubusercontent.com/EQ.../changelog.txt

If you have any questions, you can post them in this thread, otherwise please give a huge thanks to KLS for putting in the time for this!


All times are GMT -4. The time now is 07:06 AM.

Powered by vBulletin®, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.