EQEmulator Forums

EQEmulator Forums (http://www.eqemulator.org/forums/index.php)
-   General::News (http://www.eqemulator.org/forums/forumdisplay.php?f=594)
-   -   Zone MMF Files (http://www.eqemulator.org/forums/showthread.php?t=40805)

Uleat 07-29-2016 08:27 PM

I don't think the logging system is fully enabled when using the command line argument.

If you can, try starting the server and entering a zone. That should trigger the automated conversion process and there are more in-depth
messages that should be processed on a failed conversion.


EDIT: *Processed to the zone logs..

DanCanDo 07-29-2016 09:06 PM

I maxed out the logsys for zone server. I logged a toon in and zoned around.
Still nothing abnormal showing up and no entries in logs regarding conversion.

DanCanDo 07-29-2016 09:14 PM

I am not sure if this is relevant, after zoning, something I got in my gm client window,
but also the last line entered in log - [Zone Server] Got 0x0155 from world

Uleat 07-29-2016 09:20 PM

If your linux server did not have any existing mmf files, you should have gotten at least one load failure message:
https://github.com/EQEmu/Server/blob...e/map.cpp#L997

And this keeps the auto-conversion process from performing the action if an mmf already exists:
https://github.com/EQEmu/Server/blob.../map.cpp#L1089

The only real way to not have any logs messages regarding that would be if you already had an mmf file(s) in the maps folder.

Uleat 07-29-2016 09:24 PM

If that was a servertalk packet, it should be irrelevant: https://github.com/EQEmu/Server/blob...vertalk.h#L116

DanCanDo 07-29-2016 09:25 PM

Ya, one of the first things I checked after not getting anything in logs was to see if any
conversion existed in the map folder, particularly with Nexus, where I zoned, but there is
no mmf files at all. I'm going to try recompiling again and see if it makes a difference.

DanCanDo 07-29-2016 10:01 PM

Well, I tried, still the same. Can't figure out why I am not getting any errors.
I always thought of linux as more cooperative than windows (chcuckle)
I wish someone else with a linux box could try this out and see if they get
what I am getting. Zoning time is not really a concern of mine, but would be
nice to get it all smoothed out for anyone wanting to use it.

Uleat 07-29-2016 10:02 PM

I added a 'discovery' message in the Map::Load() function for when a mmf exists.

At this point, every zone boot-up should report something about the state of its mmf.

(Still not sure why you're not getting any messages for the failure...)


EDIT: I still think it's related to the dll..but, it should either be logging or crashing...

DanCanDo 07-29-2016 10:41 PM

I grabbed that last update and recompiled. Again, this is all I got :
Code:

[07-29-2016 :: 20:32:48] [Zone Server] Got 0x0023 from world:
[07-29-2016 :: 20:32:48] [Zone Server] Got 0x200e from world:
[07-29-2016 :: 20:32:48] [Zone Server] Process Received Message SyncWorldTime
[07-29-2016 :: 20:32:48] [Zone Server] Time Broadcast Packet: EQTime [02:32 pm]
[07-29-2016 :: 20:32:49] [Zone Server] Got 0x0027 from world:
[07-29-2016 :: 20:32:50] [Quests] Useless use of a variable in void context at quests/nexus/player.pl line 7.
[07-29-2016 :: 20:32:51] [Zone Server] Got 0x0155 from world:

I tried doing the manual ./zone convert_map abysmal.map and got same, previous result simply
stating conversion failed. No errors, crashes or anything. I'm stumped totally.

Uleat 07-29-2016 11:31 PM

Do you have your logsys_category 'zone_server' 'file' entry set to at least 1?

DanCanDo 07-29-2016 11:33 PM

Oh, I started with 1, then went to 3 and then to 5. Thats why I am confused.
Whether set to 1, 3 or 5 nothing changes much.
Edit: Just to add, that's restarting server each time.

DanCanDo 07-29-2016 11:47 PM

But on an off note, something ironicly funny, zoning to moors - 16 seconds (chuckle)
This is using the same windows client, but logging on to linux server without the mmf.

Uleat 07-30-2016 12:03 AM

This is what I get for a non-existing mmf:
Quote:

[07-29-2016 :: 23:25:28] [Status] Init Finished: ZoneID = 395, Time Offset = 0
[07-29-2016 :: 23:25:28] [Zone Server] Failed to load Map MMF file: 'Maps/moors.mmf' - could not open file
[07-29-2016 :: 23:25:56] [Error] Path File Maps/moors.path not found.
[07-29-2016 :: 23:25:56] [Normal] ---- Zone server moors, listening on port:7001 ----
..and for a mmf:
Quote:

[07-29-2016 :: 23:24:44] [Status] Init Finished: ZoneID = 279, Time Offset = 0
[07-29-2016 :: 23:24:44] [Zone Server] Zone map mmf found - using it in lieu of 'Maps/abysmal.map'
[07-29-2016 :: 23:24:44] [Error] Path File Maps/abysmal.path not found.
[07-29-2016 :: 23:24:44] [Normal] ---- Zone server abysmal, listening on port:7002 ----

DanCanDo 07-30-2016 12:06 AM

I'm going to duplicate that on my windows box. Maybe something is wrong with the whole
logging system on my linux box, it's weird.

POST EDIT: Not sure exactly whats going on, but looks like I have to spend a few hours
figuring out why the logs are not dishing out in either windows or linux. I'm assuming it's
something to do with the DB and logsys tables. This time, in windows, I pulled a totally
fresh source from git and set the logging at level 3 in the cmakelist for all of it.
In the DB logsys category table, I set a lot of it to level 3. So back to peq school for
better grades (chuckle)

DanCanDo 07-30-2016 03:21 AM

Ok, Uleat, I got the logsys prob sorted out, but I got the same thing you get. Nothing extra and the
conversion still won't work in the linux server. No probs at all with windows. Just devious Debian. :)
Just to clarify, the database being used on win 7 box and linux box are exact copies of same DB.

Code:

[07-30-2016 :: 01:14:04] [Status] Init Finished: ZoneID = 152, Time Offset = 0
[07-30-2016 :: 01:14:04] [Zone Server] Failed to load Map MMF file: 'Maps/nexus.mmf' - could not open file
[07-30-2016 :: 01:14:04] [Error] Path File Maps/nexus.path not found.
[07-30-2016 :: 01:14:04] [Normal] ---- Zone server nexus, listening on port:7004 ----
[07-30-2016 :: 01:14:04] [Status] Zone Bootup: nexus (152: 0)



All times are GMT -4. The time now is 12:32 AM.

Powered by vBulletin®, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.