EQEmulator Forums

EQEmulator Forums (http://www.eqemulator.org/forums/index.php)
-   Support::Linux Servers (http://www.eqemulator.org/forums/forumdisplay.php?f=588)
-   -   RoF2 crashing after scribing some spells (http://www.eqemulator.org/forums/showthread.php?t=42772)

kedra 01-12-2020 11:27 AM

RoF2 crashing after scribing some spells
 
I'm trying to stand up a new server for testing and I'm experiencing a crash after scribing spells and zoning only when using the RoF2 client.

More info:

A fresh Titanium client works fine, I'm only having this problem with a RoF2 client I obtained. It was pre-configured for the EZ server but included files that could be extracted into the install directory for a PEQ server (which I've done).

This is a new linux install using Akkadius' linux install script. I've run the export script and placed the four resulting files on the client: spells_us.txt, dbstr_us.txt, SKillCaps.txt, BaseData.txt. The first two in the root install directory, the latter two in the 'Resources' directory (I think that's correct?)

Reproducing the problem is a little inconsistent but here's an example:

Level 50 shaman runs the command: #scribespells 50

The ROF2 client will crash when zoning and the player cannot log back in until wiping those spells (or maybe just an offending spell but I haven't figured out exactly which one) from character_spells.

Besides running the export script and installing those files into the client I also attempted to import the client files to repopulate spells and dbstr tables - same problem. I've reviewed spells_us.txt, counted columns and the client file and server table seem to be identical.

I've tested with other classes and confirmed it's not just a bogus shaman spell, most caster classes will crash after running #scribespell and scribing a (usually large) range of spells but it's not always after scribing the same range of spells.

I tried to identify exactly which spells were causing this behavior but it's inconsistent, for example, I executed the following series of commands and zoned between each:

Code:

Attempt 1
#scribespells 50 1  - crash (wipe character_spells table)

Attempt 2
#scribespells 50 50 - okay
#scribespells 50 49 - okay
#scribespells 50 40 - okay
#scribespells 20 1 - okay
#scribespells 30 20 - ok (thought I was in the clear here)
#scribespells 40 30 - crash (wipe character_spells table)

Attempt 3
#scribespells 40 30 - okay this time


I've enabled mysql logging but I didn't see anything obviously wrong, although maybe I'm just not sure what I'm looking for.

As I said, titanium client works fine and getting ROF2 working at this point is really just a curiosity about checking out the new client. I suspect the ROF2 client I obtained might be the problem but I'm just wondering if anyone has any troubleshooting tips. I've been out of eqemu for a *long* and I'm pretty rusty so I could be overlooking something obvious.

Thanks for any help,

hayward6 02-18-2020 08:37 PM

I would keep looking into the client if you suspect it. Personally I prefer the older clients for stability. You were able to zone without issue before scribing the spells?

Uleat 02-19-2020 01:44 PM

There was some interesting chatter on this in discord.

Someone brought up that it could be the zlib compression library.


It is being watched ;)

hayward6 02-22-2020 10:48 AM

To see if I could recreate this issue I just started up a new server and using the ROF2 client I am having the same issue. I can zone at any level, but as soon as I have a certain number of spells scribed, forget it.

hayward6 02-22-2020 11:05 AM

Slight deviation... I am using ROF, not ROF2, but same result. So maybe it's not so much client related as it is the way spells are presented to the new client. I seem to remember this coming up before. Something about the sql tables for spells needing to be rewritten when we switched clients... Still looking around.

Uleat 02-22-2020 02:40 PM

There's a valid conversation going on in Discord about this..

..I need to check it for today's conversation and see where we stand.


All times are GMT -4. The time now is 10:05 AM.

Powered by vBulletin®, Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.