View Single Post
  #9  
Old 10-14-2020, 05:56 PM
Huppy
Demi-God
 
Join Date: Oct 2010
Location: Canada
Posts: 1,020
Default

I use this config all the time, even last week, I logged on from a friend's place. (Just in case anyone else is looking for a fix) NOTE: This config is based on my own preferences. I don't use telnet or web, etc, so those are disabled and I use the old 9000 for world, instead of 9001. But either way, it's important to have that EXTERNAL IP under world block, for private, outside connections, as well as the port forwarding in both your windows/linux firewall and router/modem firewall.

If using Windows 10, there has been known issues of a port being used by something in windows, causing problems for the server ports used. There are several things to consider that may be blocking a port. If your friends make it onto the login/server select screen, that port is open. If they make it to the character select screen, but can't get into world, chances are 9000 or 9001 is blocked somewhere. could also be an antivirus running, or any 3rd party application doing it. Grab a shovel and start digging.

Something else to consider. Those outside clients need to point their eqhost to your external IP, but if you constantly experience dynamic IP changes from your ISP, you would have to keep an eye on it, or use a service like dyndns, etc.

I realize there are pros and cons for using either private or emu public login. Trying to stay private, using the public login, creates more tedium, but I would also CAUTION, using a private login, open to the internet, it is exactly that: Open to the internet!! Something I've done, is first, I let a couple friends log on, with the "auto_create_accounts": true set in login.json. THEN, after they create their accounts, I change that to false (and restart server).

This kind of issue, gets posted randomly, and always buried in these forums, but this is the last time, I'm replying to it, haha. Have fun !!!

Code:
{
     "server" : {
          "chatserver" : {
               "host" : "192.168.0.3",
               "port" : "7778"
          },
          "database" : {
               "db" : "peq",
               "host" : "127.0.0.1",
               "password" : "******",
               "port" : "3306",
               "username" : "******"
          },
          "directories" : {
               "logs" : "logs/",
               "lua_modules" : "lua_modules/",
               "maps" : "maps/",
               "patches" : "./",
               "plugins" : "plugins/",
               "quests" : "quests/",
               "shared_memory" : "shared/"
          },
          "mailserver" : {
               "host" : "192.168.0.3",
               "port" : "7778"
          },
          "qsdatabase" : {
               "db" : "peq",
               "host" : "127.0.0.1",
               "password" : "******",
               "port" : "3306",
               "username" : "******"
          },
          "world" : {
               "address" : "142.165.58.37",		//<---------- MUST BE EXTERNAL IP
               "http" : {
                    "enabled" : "false",
                    "mimefile" : "mime.types",
                    "port" : "9080"
               },
               "key" : "qwertyu6543789zxcvbnmasdfgh",
               "localaddress" : "192.168.0.3",		// <-------- SERVER LAN ADDRESS THAT PORTS ARE FORWARDED TO
               "loginserver1" : {
                    "account" : "******",
                    "host" : "192.168.0.3",
		    "legacy" : "0",
                    "password" : "******",
                    "port" : "5998"
				},
               "loginserver2" : {
                    "account" : "",
                    "host" : "127.0.0.1",
                    "legacy" : "0",
                    "password" : "",
                    "port" : "5998"
               },
               "longname" : "Server Name",
               "shortname" : "servername",
               "tcp" : {
                    "ip" : "192.168.0.3",
                    "port" : "9000",
                    "telnet" : "disable"
               }
          },
          "zones" : {
               "defaultstatus" : "0",
               "ports" : {
                    "high" : "7500",
                    "low" : "7100"
               }
          }
     }
}
Reply With Quote