Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-20-2017, 10:56 AM
McDowell
Fire Beetle
 
Join Date: Apr 2015
Location: Taylor, Tx
Posts: 8
Default Local Login Problem SOLVED

Good news everyone!

I have fixed a problem I was having when trying to setup a new server with local login. It was working fine on my internal network but I was having trouble getting outside accounts to connect.

Before I post my fix, I would just like to thank EVERYONE in the EQemu community from the bottom of my heart.
I had tried using the instructions for setting up my server about a year ago before the automated server setup was created. It took me about a month of crying and pulling my hair out (while I am fine with servers and networks, my database skills are still at 1). I managed to get it working, but just. Never really worked "right".
This Friday I was missing EQ so came here to see if there were any advancements and sure enough the automated server software had been created.
I quickly started work and by Friday evening I was everquesting again.
Over the weekend, me and my wife logged about 40 hours on the new server, I kid you not. We had the greatest of times!
Again, I can not thank you all enough!

Ok, so back to the fix. I had followed the guide from http://wiki.eqemulator.org/p?Akkas_P...ctions-windows

In this guide, if you follow the instructions for setting up the login locally, it will work fine on the internal network but the people on the outside will be able to see the server, but will fail to log in completely and will receive the need to patch message.

This is what I found.

These 2 lines are omitted from the eqemu_config.xml from the stock automated setup and need to be put back in.

<address></address>
<localaddress></localaddress>

However, if you look at the instructions, the author shows that those two lines looks like:

<address>192.168.197.129</address>
<localaddress>127.0.0.1</localaddress>

The problem is, the <address></address> needs to be your EXTERNAL address and NOT your local one.

I corrected this and everything works fine, inside and out.

Thanks again SOOO much for all the hard work you guys have put in.

Wade McDowell

Last edited by McDowell; 03-20-2017 at 10:58 AM.. Reason: Typos!
Reply With Quote
  #2  
Old 03-20-2017, 03:14 PM
NostalgiaEQ
Banned
 
Join Date: Sep 2016
Location: us
Posts: 201
Default

Thanks a bunch! Hopefully this was my problem, friend on win 10 couldn't connect but figured it was just his system.
Reply With Quote
  #3  
Old 03-21-2017, 06:53 AM
McDowell
Fire Beetle
 
Join Date: Apr 2015
Location: Taylor, Tx
Posts: 8
Default

One important thing I forgot to mention.

ALL clients must use the External IP in their EQHost file. Inside and out.

Thanks,
Wade McDowell
Reply With Quote
  #4  
Old 03-21-2017, 07:32 AM
McDowell
Fire Beetle
 
Join Date: Apr 2015
Location: Taylor, Tx
Posts: 8
Default

<?xml version="1.0">
<server>
<world>
<shortname>McDowell</shortname>
<longname>McDowell Server</longname>

<!-- I ADDED THESE TWO LINES PER LOCAL LOGIN INSTRUCTIONS -->
<address>XXX.115.186.XXX</address>
<localaddress>127.0.0.1</localaddress>

<loginserver1>

<host>192.168.0.10</host>
<port>5998</port>
<account></account>
<password></password>

</loginserver1>

<tcp ip="127.0.0.1" port="9000" telnet="enable"/>

<key>tSgKBFspldLzufnfNp1JwnQINnPqHsm</key>

<http port="9080" enabled="true" mimefile="mime.types" />
</world>

<chatserver>
<host></host>
<port>7500</port>
</chatserver>

<mailserver>
<host></host>
<port>7500</port>
</mailserver>

<zones>
<defaultstatus>0</defaultstatus>

<ports low="7000" high="7400"/>
</zones>

<database>
<host>localhost</host>
<port>3306</port>
<username>root</username>
<password>eqemu</password>
<db>peq</db>
Reply With Quote
  #5  
Old 03-21-2017, 11:52 AM
GRUMPY's Avatar
GRUMPY
Hill Giant
 
Join Date: Oct 2016
Posts: 157
Default

If you read this thread (same topic) from a few days ago, and scroll down to my response to it. you may find it useful.

http://www.eqemulator.org/forums/showthread.php?t=27694
__________________
Smokin' in the Boys Room .....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:32 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3