Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-14-2018, 03:44 PM
Coenxai's Avatar
Coenxai
Hill Giant
 
Join Date: Dec 2013
Posts: 151
Default Movement issues?

Hey, I just got back to EQEmu. I was playing around and noticed a couple annoying issues that I was wondering if anyone had some insight on.

When you aggro a mob there's a brief delay before they send their movement update.

Also, there's a weird bouncing issue. I placed an old troll female and then viewed it with luclin models on and it would bounce.
__________________
"The true sign of intelligence is not knowledge but imagination."
Reply With Quote
  #2  
Old 11-14-2018, 04:52 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 1,956
Default

Quote:
Originally Posted by Coenxai View Post
Hey, I just got back to EQEmu. I was playing around and noticed a couple annoying issues that I was wondering if anyone had some insight on.

When you aggro a mob there's a brief delay before they send their movement update.

Also, there's a weird bouncing issue. I placed an old troll female and then viewed it with luclin models on and it would bounce.
We are in the middle of overhauling movement logic - we have some big updates on the way very soon.

We got navmesh nailed down which handles pathing AI logic very well, but another huge separate but very similar piece is the movement logic and we knew it needed to be done at some point.

It's almost done already and we'll announce soon after some soft testing with PEQ

Here is a test video in the meantime:

https://www.youtube.com/watch?v=xJRO-1WTUuY
__________________
Reply With Quote
  #3  
Old 11-14-2018, 04:57 PM
Coenxai's Avatar
Coenxai
Hill Giant
 
Join Date: Dec 2013
Posts: 151
Default

Quote:
Originally Posted by Akkadius View Post
We are in the middle of overhauling movement logic - we have some big updates on the way very soon.

We got navmesh nailed down which handles pathing AI logic very well, but another huge separate but very similar piece is the movement logic and we knew it needed to be done at some point.

It's almost done already and we'll announce soon after some soft testing with PEQ

Here is a test video in the meantime:

https://www.youtube.com/watch?v=xJRO-1WTUuY
I just noticed the navmesh. Wow! You guys have done such amazing work. It's incredible.
__________________
"The true sign of intelligence is not knowledge but imagination."
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:02 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3