Go Back   EQEmulator Home > EQEmulator Forums > Development > EQEmu Operations Center

EQEmu Operations Center Web development tools

Reply
 
Thread Tools Display Modes
  #1  
Old 06-06-2018, 09:02 PM
TheTillan
Fire Beetle
 
Join Date: Apr 2012
Posts: 2
Default Issue with EOC

My problem is a little more complex. I travel 100% for work. My internet is always a hotel isp.

I run my traffic through AirVPN and I'm trying to get my database to work with EOC.

I used Akkadius server installer. I have been setting up my server, and was able to get everything working and logged a char in, assigned GM rights.

-Firewall is open for port 3306. Cookies enabled, java enabled.
-User has been created as per wiki with updated IP. Have created user a few times.
-Have messed with # of connections per hour (default is 0; root is 0) I raised those to 999, could not connect.

Because I cannot port forward on the hotel router, I have to port forward on my VPN. The VPN will not allow me to port forward "3306" to "3306". It assigns a number for the external port and forwards the traffic to 3306 on my local PC. Example:

VPN Info: (numbers randomly generated for demonstration purposes)

Generated port: 111555
Protocol: TCP & UDP
Local Port: 3306
Mapped to Public IP: 199.222.222.1
Forwarded to Local IP: 10.0.0.1
TCP Test : Good

Canyouseeme.org shows 111555 good, 3306 no good (I believe this is working as it's supposed to.)

_________________________________________________

My thought process after this was to set the server up through 111555 instead of 3306.

My eqemu_config file:

{
"server" : {
"chatserver" : {
"host" : "",
"port" : "7500"
},
"database" : {
"db" : "peq",
"host" : "localhost",
"password" : "eqemu",
"port" : "3306",
"username" : "root"
},
"mailserver" : {
"host" : "",
"port" : "7500"
},
"qsdatabase" : {
"db" : "peq",
"host" : "localhost",
"password" : "eqemu",
"port" : "3306",
"username" : "root"
},
"webinterface" : {
"port" : "9081"
},
"world" : {
"http" : {
"enabled" : "true",
"mimefile" : "mime.types",
"port" : "9080"
},
"key" : "ad9dzL4ccStrZi2JFVlZ8JPw1lqaips",
"loginserver1" : {
"account" : "",
"host" : "login.eqemulator.net",
"legacy" : "1",
"password" : "",
"port" : "5998"
},
"loginserver2" : {
"account" : "",
"host" : "127.0.0.1",
"password" : "",
"port" : "5998"
},
"longname" : "TomsEQ - PvP - In Beta",
"shortname" : "TomsEQ",
"tcp" : {
"ip" : "127.0.0.1",
"port" : "9001"
},
"telnet" : {
"enabled" : "true",
"ip" : "0.0.0.0",
"port" : "9000"
}
},
"zones" : {
"defaultstatus" : "0",
"ports" : {
"high" : "7400",
"low" : "7000"
}
}
}
}



Within the config file, I replaced database and qsdatabase with port 111555 instead of 3306.

Once this is done, when I run start server, I cannot connect to MySQL dbase through root:localhost:111555.

-I have messed with firewall permissions for the VPN port (inbound/outbound). Had no luck, disabled rule.
-I have right clicked MySQL client from desktop and gone to the ini file. It reads:

[mysqld]
datadir=C:/Program Files/MariaDB 10.0/data
port=3306
sql_mode="STRICT_TRANS_TABLES,NO_ENGINE_SUBSTITUTI ON"
default_storage_engine=innodb
innodb_buffer_pool_size=753M
innodb_log_file_size=50M
bind-address = *
[client]
port=3306

I added in "bind-address = *" early in the troubleshooting process.

I have tried changing these ports to the VPN port 111555, does not work. I believe this file is overridden by eqemu_config file anyway.

_______________________________

This is almost futile because I can't get the server working on VPN port and I can't adjust 3306 on router, but when I do try and login from EOC I'm using the following login information:


199.222.222.1 (VPN public IP)
peq
eoc_database_user
************ (pw assigned)

I have been focusing on this issue for awhile now and feel a bit scattered. I'm going to regroup, and was hoping I could get help from the community. I'm not a professional networking or computer science guru, but I can usually follow instructions and get things working.

Please help!

Thank you

Edit: I am interested in hosting the eqemu server remotely. Is there a proven site that works with hosting servers that I should look for?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:47 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3