Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Linux Servers

Support::Linux Servers Support forum for Linux EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2020, 01:29 PM
bchilton999
Fire Beetle
 
Join Date: Sep 2010
Posts: 4
Default Canít connect to server. Black screen

I am combining 2 servers I have into one
They used to be windows server for eq server and freenas for media.

I have installed Ubuntu 20.04 LTS

I installed:

MergerFS with this guide https://www.teknophiles.com/2018/02/...with-mergerfs/
(I have 5 disks. One SSD and 4 storage drives. The 4 are merged for media. Nothing for the EQ server is on them)

Transmission preinstalled

Plex with Ubuntuís software installer

Sonarr Radarr and Jackett with https://github.com/htpcBeginner/AtoMiC-ToolKit

SSH with https://linuxize.com/post/how-to-ena...-ubuntu-18-04/

xRDP with https://www.e2enetworks.com/help/kno...-ubuntu-18-04/

Apache2 with https://www.digitalocean.com/communi...-04-quickstart

PHP with https://linuxize.com/post/how-to-ins...-ubuntu-18-04/
(No Extensions installed)

EQ server with https://eqemu.gitbook.io/server/cate...allation-linux



Everything worked fine. I was able to log into my server with both the private login server and the eq emulator login server



The next day I installed:

Samba with https://linuxize.com/post/how-to-ins...-ubuntu-18-04/

FTP with https://phoenixnap.com/kb/install-ft...-ubuntu-vsftpd



I also installed Pulseway AFTER the EQ server stopped working
https://intercom.help/pulseway/en/ar...n-debian-linux


Now I canít connect at all with the private login server. My server shows up on the eq emulator server but when I click play I get a black screen and after a couple minutes it crashes to desktop.

I tried reinstalling Everquest (ROF2. I can connect to other servers fine)
I ran the install.sh again thinking it might be file permission. No luck.

So I deleted the eqemu folder and all contents plus the SQL database. Then ran install.sh again. Still no luck.

I have triple checked the ports in both my router and Ubuntuís firewall.


My best guess is thereís a problem with file permissions or the sql database but I donít know enough about Linux to figure it out.

My only thought to get it working is to start over wipe the whole system and install the EQ server LAST but I thought I would try posting here before I spend the time to start over. Thank you for your help.


Here is my config files (I didnít try to setup the private login server after the reinstall):

eqemu_config.json

Code:
{
"server" : {
"chatserver" : {
"host" : "",
"port" : "7778"
},
"database" : {
"db" : "eqemu",
"host" : "localhost",
"password" : "XXXXX",
"port" : "3306",
"username" : "XXXXX"
},
"directories" : {
"opcodes" : "assets/opcodes/",
"patches" : "assets/patches/"
},
"files" : {
"mail_opcodes" : "assets/opcodes/mail_opcodes.conf",
"opcodes" : "assets/opcodes/opcodes.conf"
},
"mailserver" : {
"host" : "",
"port" : "7778"
},
"qsdatabase" : {
"db" : "eqemu",
"host" : "localhost",
"password" : "XXXXX",
"port" : "3306",
"username" : "XXXXX"
},
"world" : {
"key" : "XXXXX",
"loginserver1" : {
"account" : "",
"host" : "login.eqemulator.net",
"legacy" : "1",
"password" : "",
"port" : "5998"
},
"loginserver2" : {
"account" : "",
"host" : "127.0.0.1",
"password" : "",
"port" : "5998"
},
"longname" : "EQChilton",
"shortname" : "EQChilton",
"tcp" : {
"ip" : "127.0.0.1",
"port" : "9001"
},
"telnet" : {
"enabled" : "true",
"ip" : "0.0.0.0",
"port" : "9000"
}
},
"zones" : {
"defaultstatus" : "0",
"ports" : {
"high" : "7400",
"low" : "7000"
}
}
}
}
login.json
Code:
{
"account" : {
"auto_create_accounts" : true
},
"client_configuration" : {
"sod_opcodes" : "assets/opcodes/login_opcodes_sod.conf",
"sod_port" : 5999,
"titanium_opcodes" : "assets/opcodes/login_opcodes.conf",
"titanium_port" : 5998
},
"database" : {
"db" : "eqemu",
"host" : "127.0.0.1",
"password" : "XXXXX",
"port" : "3306",
"user" : "XXXXX"
},
"logging" : {
"dump_packets_in" : false,
"dump_packets_out" : false,
"trace" : false,
"world_trace" : false
},
"security" : {
"allow_password_login" : true,
"allow_token_login" : true,
"mode" : 14
},
"web_api" : {
"enabled" : true,
"port" : 6000
},
"worldservers" : {
"reject_duplicate_servers" : false,
"unregistered_allowed" : true
}
}

And Firewall ports open:
Code:
To                         Action      From
--                         ------      ----
7778/tcp                   ALLOW       Anywhere                  
3306/tcp                   ALLOW       Anywhere                  
5998/tcp                   ALLOW       Anywhere                  
5999/tcp                   ALLOW       Anywhere                  
9000/tcp                   ALLOW       Anywhere                  
9001/tcp                   ALLOW       Anywhere                  
6000/tcp                   ALLOW       Anywhere                  
9080/tcp                   ALLOW       Anywhere                  
7000:7999/tcp              ALLOW       Anywhere                  
32400/tcp                  ALLOW       Anywhere                  
3390/tcp                   ALLOW       Anywhere                  
9091/tcp                   ALLOW       Anywhere                  
8989/tcp                   ALLOW       Anywhere                  
7878/tcp                   ALLOW       Anywhere                  
9117/tcp                   ALLOW       Anywhere                  
80/tcp                     ALLOW       Anywhere                  
22/tcp                     ALLOW       Anywhere                  
20/tcp                     ALLOW       Anywhere                  
21/tcp                     ALLOW       Anywhere                  
20,21,10000:10100/tcp      ALLOW       Anywhere                  
OpenSSH                    ALLOW       Anywhere                  
40000:50000/tcp            ALLOW       Anywhere                  
990/tcp                    ALLOW       Anywhere                  
137/tcp                    ALLOW       Anywhere                  
138/tcp                    ALLOW       Anywhere                  
139/tcp                    ALLOW       Anywhere                  
445/tcp                    ALLOW       Anywhere                  
137/udp                    ALLOW       Anywhere                  
138/udp                    ALLOW       Anywhere                  
7778/tcp (v6)              ALLOW       Anywhere (v6)             
3306/tcp (v6)              ALLOW       Anywhere (v6)             
5998/tcp (v6)              ALLOW       Anywhere (v6)             
5999/tcp (v6)              ALLOW       Anywhere (v6)             
9000/tcp (v6)              ALLOW       Anywhere (v6)             
9001/tcp (v6)              ALLOW       Anywhere (v6)             
6000/tcp (v6)              ALLOW       Anywhere (v6)             
9080/tcp (v6)              ALLOW       Anywhere (v6)             
7000:7999/tcp (v6)         ALLOW       Anywhere (v6)             
32400/tcp (v6)             ALLOW       Anywhere (v6)             
3390/tcp (v6)              ALLOW       Anywhere (v6)             
9091/tcp (v6)              ALLOW       Anywhere (v6)             
8989/tcp (v6)              ALLOW       Anywhere (v6)             
7878/tcp (v6)              ALLOW       Anywhere (v6)             
9117/tcp (v6)              ALLOW       Anywhere (v6)             
80/tcp (v6)                ALLOW       Anywhere (v6)             
22/tcp (v6)                ALLOW       Anywhere (v6)             
20/tcp (v6)                ALLOW       Anywhere (v6)             
21/tcp (v6)                ALLOW       Anywhere (v6)             
20,21,10000:10100/tcp (v6) ALLOW       Anywhere (v6)             
OpenSSH (v6)               ALLOW       Anywhere (v6)             
40000:50000/tcp (v6)       ALLOW       Anywhere (v6)             
990/tcp (v6)               ALLOW       Anywhere (v6)             
137/tcp (v6)               ALLOW       Anywhere (v6)             
138/tcp (v6)               ALLOW       Anywhere (v6)             
139/tcp (v6)               ALLOW       Anywhere (v6)             
445/tcp (v6)               ALLOW       Anywhere (v6)             
137/udp (v6)               ALLOW       Anywhere (v6)             
138/udp (v6)               ALLOW       Anywhere (v6)
Reply With Quote
  #2  
Old 06-10-2020, 02:12 PM
joligario's Avatar
joligario
Developer
 
Join Date: Mar 2003
Posts: 1,414
Default

I see a bunch of TCP when you need UDP as well.
Reply With Quote
  #3  
Old 06-10-2020, 02:41 PM
bchilton999
Fire Beetle
 
Join Date: Sep 2010
Posts: 4
Default

It was working without UDP but I went ahead and opened them all for UDP as well. Still getting the black screen
Reply With Quote
  #4  
Old 07-19-2020, 10:44 AM
bchilton999
Fire Beetle
 
Join Date: Sep 2010
Posts: 4
Default

ok I reinstalled everything. Still cant connect.

I can connect to the server with the public login server fine.
I can connect to eqtitan with the public and there private login server fine.

I now get to the password input on the client and get the message a connection to the server could not be reached.

I have tryed connecting from 2 difrent computers. One of them is brand new.

Here is my config files

eqemu_config.json:
Code:
{
   "server" : {
      "chatserver" : {
         "host" : "",
         "port" : "7778"
      },
      "database" : {
         "db" : "XXXXX",
         "host" : "10.0.1.3",
         "password" : "XXXXX",
         "port" : "3306",
         "username" : "XXXXX"
      },
      "directories" : {
         "opcodes" : "assets/opcodes/",
         "patches" : "assets/patches/"
      },
      "files" : {
         "mail_opcodes" : "assets/opcodes/mail_opcodes.conf",
         "opcodes" : "assets/opcodes/opcodes.conf"
      },
      "mailserver" : {
         "host" : "",
         "port" : "7778"
      },
      "qsdatabase" : {
         "db" : "XXXXX",
         "host" : "10.0.1.3",
         "password" : "XXXXX",
         "port" : "3306",
         "username" : "XXXXX"
      },
      "world" : {
"address" : "10.0.1.3",
"localaddress" : "localhost",
               "http" : {
                    "enabled" : "true",
                    "mimefile" : "mime.types",
                    "port" : "9080"
               },
         "key" : "XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX",
            "loginserver1" : {
            "account" : "",
            "host" : "10.0.1.3",
            "password" : "",
            "port" : "5998"
         },
         "longname" : "EQChilton Skens House of Gnomes",
         "shortname" : "EQChilton",
         "tcp" : {
            "ip" : "10.0.1.3",
            "port" : "9001"
         },
         "telnet" : {
            "enabled" : "true",
            "ip" : "0.0.0.0",
            "port" : "9000"
         }
      },
      "zones" : {
         "defaultstatus" : "0",
         "ports" : {
            "high" : "7400",
            "low" : "7000"
         }
      }
   }
}
login.json:
Code:
{
   "account" : {
      "auto_create_accounts" : true
   },
   "client_configuration" : {
      "sod_opcodes" : "assets/opcodes/login_opcodes_sod.conf",
      "sod_port" : 5999,
      "titanium_opcodes" : "assets/opcodes/login_opcodes.conf",
      "titanium_port" : 5998
   },
   "database" : {
         "db" : "XXXXX",
         "host" : "10.0.1.3",
         "password" : "XXXXX",
         "port" : "3306",
         "username" : "XXXXX"
   },
   "logging" : {
      "dump_packets_in" : false,
      "dump_packets_out" : false,
      "trace" : false,
      "world_trace" : false,
"local_network" : "10.0.1."
   },
   "security" : {
      "allow_password_login" : true,
      "allow_token_login" : true,
      "mode" : 14
   },
   "web_api" : {
      "enabled" : true,
      "port" : 6000
   },
   "worldservers" : {
      "reject_duplicate_servers" : false,
      "unregistered_allowed" : true
   }
}
Firewall:
Code:
22/tcp                     ALLOW       Anywhere
9091                       ALLOW       Anywhere
32400                      ALLOW       Anywhere
7878                       ALLOW       Anywhere
7878/tcp                   ALLOW       Anywhere
8989                       ALLOW       Anywhere
9117                       ALLOW       Anywhere
3390                       ALLOW       Anywhere
Apache                     ALLOW       Anywhere
Samba                      ALLOW       Anywhere
139                        ALLOW       Anywhere
138                        ALLOW       Anywhere
137                        ALLOW       Anywhere
445                        ALLOW       Anywhere
3306                       ALLOW       Anywhere
5998                       ALLOW       Anywhere
5999                       ALLOW       Anywhere
7000:7400/tcp              ALLOW       Anywhere
7000:7400/udp              ALLOW       Anywhere
7778                       ALLOW       Anywhere
9000                       ALLOW       Anywhere
9001                       ALLOW       Anywhere
9080                       ALLOW       Anywhere
8581                       ALLOW       Anywhere
5353                       ALLOW       Anywhere
8000                       ALLOW       Anywhere
51451                      ALLOW       Anywhere
3080                       ALLOW       Anywhere
3180                       ALLOW       Anywhere
19132                      ALLOW       Anywhere
19133                      ALLOW       Anywhere
2112                       ALLOW       Anywhere
Reply With Quote
  #5  
Old 07-29-2020, 11:38 PM
bchilton999
Fire Beetle
 
Join Date: Sep 2010
Posts: 4
Default

Ok I have given up on the private login server. I deleted and reinstalled the server again. The only thing I have changed is the server name. When I log in with the public server I can create a new toon and get into the world. I can not now click to change zones and after about 30 seconds I get disconnected and sent back to the character select screen. Anyone have any idea what’s wrong? Thank you
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:15 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3