Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Linux Servers

Support::Linux Servers Support forum for Linux EQEMu users.

Reply
 
Thread Tools Display Modes
  #16  
Old 07-08-2019, 08:43 PM
whiteknight33
Sarnak
 
Join Date: Aug 2016
Location: Ohio
Posts: 65
Default

Quote:
Originally Posted by Akkadius View Post
Debian 10 and latest Ubuntu have the same issue, they share a similar package release stream since Ubuntu streams from Debian
So I assume then that the big EQEmu servers must roll with an older version of Debian.

You said before that new distro releases often times break EQEmu and have problems. Is the changelog what will eventually announce support for updated distros? (I assume eventually Ubuntu 19.04 and Debian 10 will be supported?)

Guess the moral of the story is not to jump on board with the lastest Linux distro releases. Lol
Reply With Quote
  #17  
Old 07-08-2019, 09:36 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 2,025
Default

I think the issue is not necessarily with Perl but with GCC and how are opcodes are being compiled and ultimately coming down differently down the wire causing garbled issues

I've not investigated the issue myself yet as I've been working on other things but yes, the consensus is to not typically race to the latest and that goes for many things beyond EQEmu because it may not necessarily be stable

I'm still working through some last touches with loginserver work doing a bunch of testing, found a few things I needed to take care of yet. Everything should be published and ready to go by tonight
__________________
Reply With Quote
  #18  
Old 07-09-2019, 06:39 AM
whiteknight33
Sarnak
 
Join Date: Aug 2016
Location: Ohio
Posts: 65
Default

Quote:
Originally Posted by Akkadius View Post
I think the issue is not necessarily with Perl but with GCC and how are opcodes are being compiled and ultimately coming down differently down the wire causing garbled issues

I've not investigated the issue myself yet as I've been working on other things but yes, the consensus is to not typically race to the latest and that goes for many things beyond EQEmu because it may not necessarily be stable

I'm still working through some last touches with loginserver work doing a bunch of testing, found a few things I needed to take care of yet. Everything should be published and ready to go by tonight
I started thinking Perl wasn't the problem too, just simply because Ubuntu 18.04 LTS and 19.04 both seemed to run the same version of Perl and performed differently with quests/hails.

As long as part of your testing is connecting from an outside connection and you're able to zone without getting kicked, I'm sure you'll iron everything out. lol.
Reply With Quote
  #19  
Old 07-09-2019, 05:53 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 2,025
Default

Just FYI I ended up having to spend some extra time taking care of a handful of other things LS related before preparing for release, needless to say there's been a ton of work that's gone into this

https://github.com/EQEmu/Server/compare/lsid

I'll update when things are pushed out
__________________
Reply With Quote
  #20  
Old 07-09-2019, 06:13 PM
whiteknight33
Sarnak
 
Join Date: Aug 2016
Location: Ohio
Posts: 65
Default

Quote:
Originally Posted by Akkadius View Post
Just FYI I ended up having to spend some extra time taking care of a handful of other things LS related before preparing for release, needless to say there's been a ton of work that's gone into this

https://github.com/EQEmu/Server/compare/lsid

I'll update when things are pushed out
I really do sincerely appreciate all of the time and effort you've spent (and continue to spend) in order to keep EQEmu evolving. I can hardly wait to play with my friend and for him to keep a constant connection.
Reply With Quote
  #21  
Old 07-10-2019, 06:21 PM
whiteknight33
Sarnak
 
Join Date: Aug 2016
Location: Ohio
Posts: 65
Default

Quote:
Originally Posted by Akkadius View Post
Just FYI I ended up having to spend some extra time taking care of a handful of other things LS related before preparing for release, needless to say there's been a ton of work that's gone into this

https://github.com/EQEmu/Server/compare/lsid

I'll update when things are pushed out
I'm an idiot and I think I just realized what I'm supposed to do with the link you provided. lol...

When updating my files manually, the following files didn't exist at all from the Linux installer, so I manually created them.

/loginserver/
account_management.cpp
loginserver_webserver.cpp
loginserver_command_handler.cpp


/loginserver/login_util
login_schema.sql

/common/
database.cpp

And, probably an error on my part, I attempted to compile everything with the latest version of all the files and it didn't work. lol...

Quote:
-- Boost version: 1.69.0
-- Version: 5.3.0
-- Build type: RelWithDebInfo
-- CXX_STANDARD: 11
-- Configuring done
-- Generating done
-- Build files have been written to: /home/eqemu/server_source/Server/build
Scanning dependencies of target common
[ 0%] Building CXX object common/CMakeFiles/common.dir/base_packet.cpp.o
[ 0%] Building CXX object common/CMakeFiles/common.dir/classes.cpp.o
[ 0%] Building CXX object common/CMakeFiles/common.dir/compression.cpp.o
[ 1%] Building CXX object common/CMakeFiles/common.dir/condition.cpp.o
[ 1%] Building CXX object common/CMakeFiles/common.dir/crash.cpp.o
[ 1%] Building CXX object common/CMakeFiles/common.dir/crc16.cpp.o
[ 1%] Building CXX object common/CMakeFiles/common.dir/crc32.cpp.o
[ 2%] Building CXX object common/CMakeFiles/common.dir/database.cpp.o
/home/eqemu/server_source/Server/common/database.cpp: In member function ‘uint32 Database::CreateAccount(const char*, const char*, int16, const char*, uint32)’:
/home/eqemu/server_source/Server/common/database.cpp:239:2: error: ‘LogInfo’ was not declared in this scope
239 | LogInfo("Account Attempting to be created: [{0}:{1}] status: {2}", loginserver, name, status);
| ^~~~~~~
/home/eqemu/server_source/Server/common/database.cpp: In member function ‘uint32 Database::GetAccountIDFromLSID(const string&, uint32, char*, int16*)’:
/home/eqemu/server_source/Server/common/database.cpp:1228:15: error: ‘fmt’ has not been declared
1228 | auto query = fmt::format(
| ^~~
/home/eqemu/server_source/Server/common/database.cpp: In member function ‘void Database::LoadLogSettings(EQEmuLogSys::LogSettings *)’:
/home/eqemu/server_source/Server/common/database.cpp:2178:4: error: ‘LogInfo’was not declared in this scope
2178 | LogInfo(
| ^~~~~~~
/home/eqemu/server_source/Server/common/database.cpp:2183:24: error: ‘fmt’ has not been declared
2183 | auto inject_query = fmt::format(
| ^~~
make[2]: *** [common/CMakeFiles/common.dir/build.make:154: common/CMakeFiles/common.dir/database.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:91: common/CMakeFiles/common.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
(Edited it to how the red where the terminal put it, for easier reading.)
Reply With Quote
  #22  
Old 07-10-2019, 06:23 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 2,025
Default

The link was just showing the sheer magnitude of work and changes gone into it, I never implied pull it down and start monkeying with it

As far as your authentication issues are concerned, I would make sure that your worldserver "address" variable is set to your public address, this can cause weird issues with zoning and handoffs much less able to handoff from Loginserver to worldserver at all
__________________
Reply With Quote
  #23  
Old 07-10-2019, 06:34 PM
whiteknight33
Sarnak
 
Join Date: Aug 2016
Location: Ohio
Posts: 65
Default

Quote:
Originally Posted by Akkadius View Post
The link was just showing the sheer magnitude of work and changes gone into it, I never implied pull it down and start monkeying with it
Whoops. I thought I was supposed to test it out. Well, that explains that.

Quote:
Originally Posted by Akkadius View Post
As far as your authentication issues are concerned, I would make sure that your worldserver "address" variable is set to your public address, this can cause weird issues with zoning and handoffs much less able to handoff from Loginserver to worldserver at all
Yeah, at first outside connections weren't able to connect all. A while back, someone here helped me switch it to have both an "address" and a "localaddress" and that allowed both LAN and outside connections to connect. Everything works great until it comes time to zone.
Reply With Quote
  #24  
Old 07-10-2019, 07:49 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 2,025
Default

I want to run these changes through a production environment and closely monitor for a while, so I will not be rushing to push this mainline.

If you want to actually try out this loginserver on your server in the interm, I'd be happy to help you get it setup on Discord.

I'm getting ready to go camping in Canada today but I should be able to help in an hour or so if it is a route you'd like to go
__________________
Reply With Quote
  #25  
Old 07-10-2019, 07:55 PM
whiteknight33
Sarnak
 
Join Date: Aug 2016
Location: Ohio
Posts: 65
Default

Quote:
Originally Posted by Akkadius View Post
I want to run these changes through a production environment and closely monitor for a while, so I will not be rushing to push this mainline.

If you want to actually try out this loginserver on your server in the interm, I'd be happy to help you get it setup on Discord.

I'm getting ready to go camping in Canada today but I should be able to help in an hour or so if it is a route you'd like to go
I would really like that.
Reply With Quote
  #26  
Old 07-10-2019, 09:05 PM
Huppy
Dragon
 
Join Date: Oct 2010
Location: Canada
Posts: 892
Default

Quote:
Originally Posted by Akkadius View Post
I'm getting ready to go camping in Canada today
Sorry for an off-topic note. Wildfires going on in Ontario, depending on where you're going.
__________________
Everyday I wake up with a whole new attitude ....
Reply With Quote
  #27  
Old 07-10-2019, 09:19 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 2,025
Default

Quote:
Originally Posted by Huppy View Post
Sorry for an off-topic note. Wildfires going on in Ontario, depending on where you're going.
Winnipeg

-------------
__________________
Reply With Quote
  #28  
Old 07-10-2019, 09:39 PM
Huppy
Dragon
 
Join Date: Oct 2010
Location: Canada
Posts: 892
Default

Quote:
Originally Posted by Akkadius View Post
Winnipeg

-------------
Should of done that next month, I could of stopped by for coffee, lol. (I'm only 6 hours from there), but too busy this month with things.
__________________
Everyday I wake up with a whole new attitude ....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:30 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3