Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-22-2018, 04:45 PM
skywalker646
Fire Beetle
 
Join Date: Sep 2018
Posts: 28
Default Public server example

Hi all,

Does anyone have an example of a public server with a private login? More specifically the json file and the login file

Qould love to see how people have it set up
Reply With Quote
  #2  
Old 10-22-2018, 10:01 PM
prestanneth
Fire Beetle
 
Join Date: Jul 2015
Posts: 10
Default

Sample below.
I've added the public login for a more complete version as you can use both with no problems.
if only want local just remove the loginserver2 section and rename loginserver1 to loginserver..


eqemu_config.json


{
"DELETE_THIS_COMMENT" : "10.x.x.x is local static ip (i prefer to using 127.0.0.1) 136.147.168.2 = your external world ip - Admin/Password is non hashed creds referenced in login.ini tables - internal and external use loginserver1,loginserver2 confs or just have 1 called loginserver. legacy tag must be set 0 for local, 1 is only req for eqemu public loginserver (or was..)",

"server": {
"world": {
"loginserver1": {
"legacy":"0",
"host": "136.147.168.2",
"port": "5999",
"account": "Admin",
"password": "Password"
},
"tcp": {
"ip": "136.147.168.2",
"port": "9001"
},
"address": "136.147.168.2",
"longname": "Elves R Real",
"loginserver2": {
"legacy": "1",
"host": "login.eqemulator.net",
"port": "5998",
"account": "",
"password": ""
},
"telnet": {
"port": "9000",
"enabled": "true",
"ip": "136.147.168.2"
},
"key": "kentaikwondo_uniquestringn%",
"http": {
"port": "9080",
"enabled": "true",
"mimefile": "mime.types"
},
"shortname": "IRLRealm"
},
"chatserver": {
"host": "136.147.168.2",
"port": "7500"
},
"mailserver": {
"host": "136.147.168.2",
"port": "7500"
},
"database": {
"host": "10.1.1.176",
"port": "3306",
"username": "dbuser",
"password": "dbpassword",
"db": "peq"
},
"zones": {
"defaultstatus": "0",
"ports": {
"low": "7000",
"high": "7400"
}
},
"qsdatabase": {
"host": "10.1.1.176",
"port": "3306",
"username": "dbuser",
"password": "dbpassword",
"db": "peq"
}
}
}

Login.ini

[database]
host = 10.1.1.176
port = 3306
db = peq
user = dbuser
password = dbpassword
subsystem = MySQL

[options]
unregistered_allowed = TRUE
reject_duplicate_servers = FALSE
trace = TRUE
world_trace = TRUE
dump_packets_in = FALSE
dump_packets_out = FALSE
listen_port = 5999
local_network = 136.147.168. /*<<------- leave last xxx out here */
auto_create_accounts = TRUE


[security]
plugin = EQEmuAuthCrypto
mode = 5

[Titanium]
port = 5998
opcodes = login_opcodes.conf

[SoD]
port = 5999
opcodes = login_opcodes_sod.conf

[schema]
account_table = tblLoginServerAccounts
world_registration_table = tblWorldServerRegistration
world_admin_registration_table = tblServerAdminRegistration
world_server_type_table = tblServerListType
Reply With Quote
  #3  
Old 10-22-2018, 10:34 PM
skywalker646
Fire Beetle
 
Join Date: Sep 2018
Posts: 28
Default

thanks! i'll fiddle around with this
Reply With Quote
  #4  
Old 11-02-2018, 12:31 PM
Asylum
Sarnak
 
Join Date: Jun 2013
Posts: 80
Default

Hello everyone, back from a long break and want to continue to develop my server that began back in 2013, last modified in 2017. I reinstalled the software using Akka's newest autoinstaller (WAAAAY better than the circa 2016-17 version, nice work!), and easier than the old manual way. I can log in just fine, create content, et cetera. Others are having an issue logging into the server. It appears on the server list "The Fallen Empire EQEmuServer" but testing has shown no one else can log in except me locally. Testing was done with both Titanium and RoF2 clients. Perhaps there is some small thing I overlooked in the eqemu_config.json or login.ini files (both posted below for critique).

eqemu_config.json

{
"server" : {
"chatserver" : {
"host" : "",
"port" : "7778"
},
"database" : {
"db" : "peq",
"host" : "localhost",
"password" : "**********",
"port" : "3306",
"username" : "root"
},
"mailserver" : {
"host" : "",
"port" : "7778"
},
"qsdatabase" : {
"db" : "peq",
"host" : "localhost",
"password" : "**********",
"port" : "3306",
"username" : "root"
},
"webinterface" : {
"port" : "9081"
},
"world" : {
"http" : {
"enabled" : "true",
"mimefile" : "mime.types",
"port" : "9080"
},
"key" : "*************************",
"loginserver1" : {
"account" : "",
"host" : "login.eqemulator.net",
"legacy" : "1",
"password" : "",
"port" : "5998"
},
"loginserver2" : {
"account" : "",
"host" : "192.168.0.10",
"password" : "",
"port" : "5998"
},
"longname" : "The Fallen Empire EQEmuServer",
"shortname" : "The Fallen Empire",
"tcp" : {
"ip" : "127.0.0.1",
"port" : "9001"
},
"telnet" : {
"enabled" : "true",
"ip" : "0.0.0.0",
"port" : "9000"
}
},
"zones" : {
"defaultstatus" : "0",
"ports" : {
"high" : "7400",
"low" : "7000"
}
}
}
}


login.ini

[database]
host = localhost
port = 3306
db = peq
user = root
password = *********
subsystem = MySQL

[options]
unregistered_allowed = TRUE
reject_duplicate_servers = FALSE
trace = TRUE
world_trace = FALSE #<-- is this the issue???
dump_packets_in = FALSE
dump_packets_out = FALSE
listen_port = 5998
local_network = 192.168.0.10
auto_create_accounts = TRUE

[security]
plugin = EQEmuAuthCrypto
mode = 5

[Titanium]
port = 5998
opcodes = login_opcodes.conf

[SoD]
port = 5999
opcodes = login_opcodes_sod.conf

[schema]
account_table = loginserver_server_accounts
world_registration_table = loginserver_world_server_registration
world_admin_registration_table = loginserver_server_admin_registration
world_server_type_table = loginserver_server_list_type
Reply With Quote
  #5  
Old 11-02-2018, 01:19 PM
Maze_EQ
Demi-God
 
Join Date: Mar 2012
Posts: 1,056
Default

did you forward ports on your network?

From your router....
__________________
"No, thanks, man. I don't want you fucking up my life, too."

Skype:
Comerian1
Reply With Quote
  #6  
Old 11-02-2018, 01:33 PM
Asylum
Sarnak
 
Join Date: Jun 2013
Posts: 80
Default

Hi Maze. Thanks for the reply.

I used Akka's autoinstaller and it should open the 7000-7100 and other used ports right? Or, do I need to manually go into my router/modem (Motorola SBG6580-G22 and forward them?

Under IPv4: I set the following ports to be forwarded (5998-5999, 7000-7100, 9000) both TCP and UDP.

Forwarded Ports
External IP Address &
Start/End Port Local IP Address &
Start/End Port Description Protocol Forwarding
0.0.0.0
7000 / 7100
192.168.0.10
7000 / 7100
EQEmu
BOTH
Yes
0.0.0.0
9000 / 9000
192.168.0.10
9000 / 9000
EQEmu
BOTH
Yes
0.0.0.0
5998 / 5999
192.168.0.10
5998 / 5999
EQEmu
BOTH
Yes
Reply With Quote
  #7  
Old 11-02-2018, 02:06 PM
Asylum
Sarnak
 
Join Date: Jun 2013
Posts: 80
Default

Server "The Fallen Empire EQEmuServer" is up with modified ports opened. I'll know if anyone successfully logs in by the logs or you can post here if you tried successfully (or status/result if unsuccessful).

Thanks Maze and everyone else.
Reply With Quote
  #8  
Old 11-02-2018, 06:25 PM
prestanneth
Fire Beetle
 
Join Date: Jul 2015
Posts: 10
Default

not sure your status based on last comment but some notes here:

All of your config's ips are local, if you want the server to be also public you need to tell the world where you are.
( primarily setting the ips based on your "internet" world address. )

you also have a mixture of 127.0.0.1, "localhost" and 192.168.0.10
suggest to use just the actual 192.168.0.10 to keep it clean.

( The only ip that should be 192.168.0.10 is the databases ".host" )

https://www.myglobalip.com/
that is your internet address to use.


look through the sample i posted initially, your missing the "address", set this to internet address so loginserver1 (eqemulator) login knows where you are.

in .json
Everywhere I've wrote 10.1.1.176 that's equal to your 192.168.0.10
Everywhere I've wrote 136.147.168.2 that's equal to your internet address

in .ini
world_trace = FALSE #<-- is this the issue???
NO
but suggest to change
local_network = 192.168.0.10 to your world address and leave off the last number per example, otherwise i doubt even your lan would work let alone wan.
example: 123.456.789. <-- no last number otherwise it would be specific to 1 pc , not lan/wan.
Reply With Quote
  #9  
Old 11-02-2018, 06:41 PM
prestanneth
Fire Beetle
 
Join Date: Jul 2015
Posts: 10
Default

also should mention, a better method of testing/debugging problems is to simplify.
i.e Remove/ not use, the local login server, so your'e only dealing with 1.

i.e
delete loginserver2 section
rename loginserver1 to loginserver
set parameters to eqemulators
set all ips correct to tell the world where you are.
test.

once you change your settings so it works for you with only eqemulator loginserver, then there's a better chance it will work for others.

if it all works, then revisit if you need to add back local loginserver.
Reply With Quote
  #10  
Old 11-02-2018, 07:24 PM
Asylum
Sarnak
 
Join Date: Jun 2013
Posts: 80
Default

I think I understood those changes and made them correctly; the files are not in the same order but the hierarchy should match. I hope I remembered how to embed the code.

eqemu_config.json
Code:
{
     "server" : {
          "chatserver" : {
               "host" : "my ip address",
               "port" : "7778"
          },
          "database" : {
               "db" : "peq",
               "host" : "192.168.0.10",
               "password" : "******",
               "port" : "3306",
               "username" : "root"
          },
          "mailserver" : {
               "host" : "my ip address",
               "port" : "7778"
          },
          "qsdatabase" : {
               "db" : "peq",
               "host" : "192.168.0.10",
               "password" : "******",
               "port" : "3306",
               "username" : "root"
          },
          "webinterface" : {
               "port" : "9081"
          },
          "world" : {
				"address": "my ip address",
				"http" : {
                    "enabled" : "true",
                    "mimefile" : "mime.types",
                    "port" : "9080"
               },
               "key" : "longstringofnonsensekey",
               "loginserver1" : {
                    "account" : "",
                    "host" : "login.eqemulator.net",
                    "legacy" : "1",
                    "password" : "",
                    "port" : "5998"
               },
               "loginserver2" : {
					"account" : "",
                    "host" : "192.168.0.10",
                    "password" : "",
                    "port" : "5998" <-- not 5999? does it matter here?
               },
               "longname" : "The Fallen Empire EQEmuServer",
               "shortname" : "The Fallen Empire",
               "tcp" : {
                    "ip" : "my ip address",
                    "port" : "9001"
               },
               "telnet" : {
                    "enabled" : "true",
                    "ip" : "my ip address",
                    "port" : "9000"
               }
          },
          "zones" : {
               "defaultstatus" : "0",
               "ports" : {
                    "high" : "7400",
                    "low" : "7000"
               }
          }
     }
}
login.ini

Code:
[database]
host = myipaddress
port = 3306
db = peq
user = root
password = eqemu
subsystem = MySQL

[options]
unregistered_allowed = TRUE
reject_duplicate_servers = FALSE
trace = TRUE
world_trace = FALSE
dump_packets_in = FALSE
dump_packets_out = FALSE
listen_port = 5998
local_network = 12.345.678. <-- left off the last number set
auto_create_accounts = TRUE

[security]
plugin = EQEmuAuthCrypto
mode = 5

[Titanium]
port = 5998
opcodes = login_opcodes.conf

[SoD]
port = 5999
opcodes = login_opcodes_sod.conf

[schema]
account_table = loginserver_server_accounts
world_registration_table = loginserver_world_server_registration
world_admin_registration_table = loginserver_server_admin_registration
world_server_type_table = loginserver_server_list_type
Reply With Quote
  #11  
Old 11-02-2018, 07:36 PM
Asylum
Sarnak
 
Join Date: Jun 2013
Posts: 80
Default

With those changes, server still boots up and I'm still able to log in from same machine of course. I cannot test the login ability from others at the moment.

New: the loginserver.exe window keeps reinitializing nonstop now (not good).
Reply With Quote
  #12  
Old 11-02-2018, 07:43 PM
prestanneth
Fire Beetle
 
Join Date: Jul 2015
Posts: 10
Default

Code:
   "loginserver2" : {
					"account" : "",
                    "host" : "192.168.0.10",
                    "password" : "",
                    "port" : "5998" <-- not 5999? does it matter here?
               },
account and password need to match the database.
default is Admin / Password
in your case check the table :
loginserver_server_admin_registration

port 5998 titanium / 5999 rof2
Reply With Quote
  #13  
Old 11-02-2018, 07:47 PM
prestanneth
Fire Beetle
 
Join Date: Jul 2015
Posts: 10
Default

Code:
Login.ini

[database]
host = 10.1.1.176 <- check here is the local "ip" not world" ip
apart from those two issues looks good setting wise.
Reply With Quote
  #14  
Old 11-02-2018, 08:44 PM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,475
Default

No, leave the port at 5998 for loginserver2.

You only change the port in the client's eqhost.txt file.
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #15  
Old 11-06-2018, 02:07 PM
FievelMousey
Sarnak
 
Join Date: Jan 2004
Posts: 93
Default

you need port forward 9001 also
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:15 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3