Go Back   EQEmulator Home > EQEmulator Forums > General > General::News

General::News EQemu news posts.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-12-2016, 02:40 AM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 1,771
Default Linux Installers & Github Readme Updated & EQEmu Server Management Framework Overhaul

Hello everyone.

Have quite a few different things to announce in a quick news post here. A lot of time has been put into these things.

We now have standardized installers for the following Linux Distributions:
  1. Ubuntu
  2. Debian
  3. Fedora
  4. CentOS

The install script can be found here:

https://github.com/EQEmu/Server#server-installs

Thanks N0ctrnl for assisting in getting some of these other platforms supported in the installer. Thanks to those in the coders channel that have assisted in testing installations in effort to make things simplified and easier to install/manage overall.

Github Read Me has been Updated

  • You will find that the Github Readme has had a few things added to it

Read up on the Massive EQEmu Server Management framework overhaul:
Post comments and questions below.
__________________
Reply With Quote
  #2  
Old 09-12-2016, 09:34 AM
DanCanDo's Avatar
DanCanDo
Discordant
 
Join Date: May 2016
Location: Above Hell
Posts: 436
Default

I especially like the options of CLI arguments.
Thank you very much Akkadius, N0ctrnl (and others) for stuff like this. All that effort you
guys put in to development does not go unappreciated.
__________________
Project Insect Completed
Reply With Quote
  #3  
Old 09-12-2016, 11:32 PM
rhyotte
Hill Giant
 
Join Date: Jul 2012
Location: So.Cal.
Posts: 214
Default

I can tell you for sure, This Rocks!

Thank You!!
Reply With Quote
  #4  
Old 09-13-2016, 10:33 AM
jpyou127's Avatar
jpyou127
Hill Giant
 
Join Date: Nov 2005
Posts: 233
Default

Getting these error on the linux installer for debian 8:

"WARNING: The following packages cannot be authenticated"
"There are problems and -y was used without --force-yes"

I have a fresh Debian 8 install "putty" to the server and logged in as "root".

Running this command set:

"wget --no-check-certificate https://raw.githubusercontent.com/EQ...ler/install.sh -O install.sh && chmod 755 install.sh && ./install.sh"

Basically it stops because nothing can be installed.


Celestial
Reply With Quote
  #5  
Old 09-13-2016, 12:28 PM
N0ctrnl's Avatar
N0ctrnl
Discordant
 
Join Date: Jan 2007
Posts: 417
Default

Debian 8... what? If it's not 8.5 I don't think it's been tested.

Also, details details details. There's not much in what you've posted.
__________________
Ender - Lead GM/Developer
Vegarlson Asylum Server - http://www.vegarlson-server.org/
Reply With Quote
  #6  
Old 09-13-2016, 01:36 PM
jpyou127's Avatar
jpyou127
Hill Giant
 
Join Date: Nov 2005
Posts: 233
Default

This errors on the install of packages.
A package is attempted as an install and it gives the first error: "WARNING: The following packages cannot be authenticated".
At the end of the attempt it gives this error: "There are problems and -y was used without --force-yes"



Celestial
Reply With Quote
  #7  
Old 09-13-2016, 01:53 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 1,771
Default

Make sure you have an Internet connection
__________________
Reply With Quote
  #8  
Old 09-13-2016, 02:03 PM
N0ctrnl's Avatar
N0ctrnl
Discordant
 
Join Date: Jan 2007
Posts: 417
Default

Debian 8.5?
__________________
Ender - Lead GM/Developer
Vegarlson Asylum Server - http://www.vegarlson-server.org/
Reply With Quote
  #9  
Old 09-13-2016, 02:09 PM
jpyou127's Avatar
jpyou127
Hill Giant
 
Join Date: Nov 2005
Posts: 233
Default

I have an internet connection as its a cloud hosted server, and I can ping google also.

And it does connect to run the initial script located at the URL above.

Debian 8 is the flavor thats offered. Here is an Error exactly as is repeated.


WARNING: The following packages cannot be authenticated!
libasan1 libatomic1 libcilkrts5 libisl10 libcloog-isl4 libgomp1 libitm1 liblsan0 libmpfr4 libquadmath0 libtsan0 libubsan0 libmpc3 binutils libc-dev-bin linux-libc-dev
libc6-dev cpp-4.9 cpp libgcc-4.9-dev gcc-4.9 gcc libstdc++-4.9-dev g++-4.9 g++ make libdpkg-perl dpkg-dev build-essential libfakeroot fakeroot libalgorithm-diff-perl
libalgorithm-diff-xs-perl libalgorithm-merge-perl libfile-fcntllock-perl manpages-dev
E: There are problems and -y was used without --force-yes


Celestial
Reply With Quote
  #10  
Old 09-13-2016, 02:10 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 1,771
Default

Quote:
Originally Posted by jpyou127 View Post
I have an internet connection as its a cloud hosted server, and I can ping google also.

And it does connect to run the initial script located at the URL above.

Debian 8 is the flavor thats offered.


Celestial
It's an issue related to the image they provide you then.

http://stackoverflow.com/questions/2...n-ubuntu-14-04
__________________
Reply With Quote
  #11  
Old 09-13-2016, 02:11 PM
jpyou127's Avatar
jpyou127
Hill Giant
 
Join Date: Nov 2005
Posts: 233
Default

Roger that.

Celestial
Reply With Quote
  #12  
Old 09-13-2016, 02:16 PM
jpyou127's Avatar
jpyou127
Hill Giant
 
Join Date: Nov 2005
Posts: 233
Default

Ok I just ran apt-get update real quick to check and now its installing packages.

My apologies =)

Celestial
Reply With Quote
  #13  
Old 09-13-2016, 04:52 PM
N0ctrnl's Avatar
N0ctrnl
Discordant
 
Join Date: Jan 2007
Posts: 417
Default

Mileage could vary depending on the customization of the OS, as you've seen. Just remember - Details are the key. Specific errors, OS versions, etc.

Glad you're making progress
__________________
Ender - Lead GM/Developer
Vegarlson Asylum Server - http://www.vegarlson-server.org/
Reply With Quote
  #14  
Old 09-15-2016, 04:12 PM
rudeboy88's Avatar
rudeboy88
Fire Beetle
 
Join Date: Oct 2007
Location: West Freeport
Posts: 27
Default

Tried this today with a fresh minimal install of debian 8.5 on a vbox and it worked wonders with no fuss, thanks!
__________________
| Swashbuckler Rudeboy Two Tone | Greenmist
Reply With Quote
  #15  
Old 09-23-2016, 10:12 PM
DanCanDo's Avatar
DanCanDo
Discordant
 
Join Date: May 2016
Location: Above Hell
Posts: 436
Default

I was curious about the current install stats shown on this page:
https://github.com/EQEmu/Server/blob/master/README.md
It shows 726 Windows (at the moment) and 59 Linux.
Are those stats based on the amount of installs from the installer script ?
If it is, that's a flabergasting number (chuckle)
__________________
Project Insect Completed
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:14 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3