Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-20-2021, 04:37 AM
Sintox
Fire Beetle
 
Join Date: May 2017
Posts: 5
Default "Your spells interrupted" every time I cast

Every time I cast any spell it says "your spell was interrupted" and I go from full mana to zero. It does this on regular and gm accounts.

I tried a fresh server install using EQEmu Server Installer Files. I have used both Titanium and ROF2 clients and I have tried it on my desktop and laptop.

I have not modified the DB in any way, it is as it was fresh off the download.

I read another post with same problem that making it to level 2 fixed it, a fresh EQServer install fixed it, these didn't work for me.

I'm still total noob when it comes to all this Dev stuff. I can make easy changes to stuff in the rule_values and places like that but nothing as complex as to why I keep getting interrupted and lose 100% mana.

If someone could look into this that would be awesome.
Reply With Quote
  #2  
Old 01-20-2021, 09:20 AM
joligario's Avatar
joligario
Developer
 
Join Date: Mar 2003
Posts: 1,447
Default

What zone?
Reply With Quote
  #3  
Old 01-20-2021, 02:27 PM
Sintox
Fire Beetle
 
Join Date: May 2017
Posts: 5
Default

I only tried panieel and halas.

I did bump a gm character to 50 and maxed out casting skills. I was able to cast after that. So i tried that with a regular level 1 character, maxed out casting skills for that level, still was not able to cast.
Reply With Quote
  #4  
Old 01-20-2021, 04:45 PM
Sintox
Fire Beetle
 
Join Date: May 2017
Posts: 5
Default

I Just bumped a character to level 3 and now my spells don't get interrupted and I'm able to cast. My skills are also going up also.

Maybe someone can figure out why you get interrupted and go to zero mana at level 1 & 2.
Reply With Quote
  #5  
Old 01-29-2021, 04:58 PM
hayward6
Forum Guide
 
Join Date: Jul 2005
Posts: 460
Default

I've seen this before and I don't think it's a product of the emulator directly. Usually on a live server you start out with a single spell and you use that spell to fight and gain skills ups and experience and coin to by other spells. You also talk to your trainer and can advance skills like that.

As a server op you probably just summon or scribe all of your spells and before you even get to level 2, you're trying to cast spells you barely have the mana for. I'm not a coder, so I deal with these things in a different way. If you really hate it, maybe setup a script to auto skill up new players to say 5 or 10 skill points. It could get very detailed and difficult, or real simple... I believe you can also tweak the interruption chance, but that might mess you up in other areas.
__________________
Sayin Silverwolf
Server Op of The Sandbox (Non-Legit)
Reply With Quote
  #6  
Old 01-30-2021, 04:16 PM
Sintox
Fire Beetle
 
Join Date: May 2017
Posts: 5
Default

Thanks for the reply.

What you said would make sense if I was getting "your spell fizzled", but I'm getting "your spell was interrupted".

I'm getting interrupted standing still out of combat at level 1 & 2. I maxed out skills for those levels and still got "you spell was interrupted". I then go from 25 mana to zero mana after one interrupt. I should get 4 or 5 fizzles before zero mana. Once I hit level 3 I was able to cast like normal. I made level 3 with zero skills and was able to cast like normal.

I can't figure out why I get interrupted at levels 1 & 2 and lose all mana after each cast attempt. I'm almost positive it has to do with the levels and the DB.

Thanks,
David
Reply With Quote
  #7  
Old 01-30-2021, 07:17 PM
Huppy
Demi-God
 
Join Date: Oct 2010
Location: Canada
Posts: 1,100
Default

Quote:
Originally Posted by Sintox View Post
I tried a fresh server install using EQEmu Server Installer Files
Quote:
Originally Posted by Sintox View Post
I'm almost positive it has to do with the levels and the db
If the problem was the db (server-side), you would not be the only person having this problem right now. There would be a slew of people reporting it, lately.

If you haven't already, try a fresh, clean install of your client and export the spell files from your server to client.
Reply With Quote
  #8  
Old 02-19-2021, 04:37 PM
XxTRAINEExX
Fire Beetle
 
Join Date: Jan 2006
Posts: 13
Default

Hey Sintox, did you ever get this resolved? I'm seeing the exact same issue on my server. Setting the person to 255 corrects the issue but that's not a viable work-around.

Brian
Reply With Quote
  #9  
Old 02-24-2021, 10:04 PM
ToXiN06
Fire Beetle
 
Join Date: Apr 2008
Location: Stuff
Posts: 2
Default

Set the rule Character:OldMinMana to true

Credit to Gangsta on Discord
Reply With Quote
  #10  
Old 02-26-2021, 01:20 PM
Diamatr
Fire Beetle
 
Join Date: Feb 2021
Posts: 9
Default

Thanks ToXin06. I needed to fix that as well. I looked at the peq table and I cant see that field there. In which table/file do I need to change that value?
Reply With Quote
  #11  
Old 02-26-2021, 02:00 PM
Diamatr
Fire Beetle
 
Join Date: Feb 2021
Posts: 9
Default

Ignore my question. I found it
Reply With Quote
  #12  
Old 03-01-2021, 03:23 PM
XxTRAINEExX
Fire Beetle
 
Join Date: Jan 2006
Posts: 13
Default

Quote:
Originally Posted by ToXiN06 View Post
Set the rule Character:OldMinMana to true

Credit to Gangsta on Discord
Figured it out! For those of you reading this after me... log in to the game and type the following:

#rules set Character:OldMinMana true

Brian
Reply With Quote
  #13  
Old 03-01-2021, 04:03 PM
XxTRAINEExX
Fire Beetle
 
Join Date: Jan 2006
Posts: 13
Default

Quote:
Originally Posted by ToXiN06 View Post
Set the rule Character:OldMinMana to true

Bummer I spoke too soon. Does a characters status need to be higher than 0? At zero it still does this standard "Spell is interupted" and pushes their mana all the way down to zero.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:55 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3