Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-09-2018, 11:49 AM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default Connecting to Server after Update to. Json

I just updated my server that I was able to login to and other people could as well to the json config and now my server doesn't even show up as an option in the server list. All of my ports and stuff are still the same. Do i have to edit anything in the json config to make my server available again? If so what edits do I need to make?
Reply With Quote
  #2  
Old 02-09-2018, 07:15 PM
Kingly_Krab's Avatar
Kingly_Krab
Developer
 
Join Date: May 2013
Location: United States
Posts: 1,500
Default

Post your .JSON with your passwords and sensitive information removed.
__________________
For Project 1999 related issues, check here.

Click here for the EQEmulator Wiki.
Reply With Quote
  #3  
Old 02-09-2018, 07:40 PM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

Everywhere it said removed was a password and username that was input


Quote:
{
"server" : {
"chatserver" : {
"host" : "",
"port" : "7500"
},
"database" : {
"db" : "peq",
"host" : "localhost",
"password" : "removed",
"port" : "3306",
"username" : "removed"
},
"mailserver" : {
"host" : "",
"port" : "7500"
},
"qsdatabase" : {
"db" : "peq",
"host" : "localhost",
"password" : "removed",
"port" : "3306",
"username" : "removed"
},
"webinterface" : {
"port" : "9081"
},
"world" : {
"http" : {
"enabled" : "true",
"mimefile" : "mime.types",
"port" : "9080"
},
"key" : "z0mb8f2ByUdq23ul2oHRRRiZvYmAZhk",
"loginserver1" : {
"account" : "",
"host" : "login.eqemulator.net",
"password" : "",
"port" : "5998"
},
"loginserver2" : {
"account" : "",
"host" : "127.0.0.1",
"password" : "",
"port" : "5998"
},
"longname" : "Vengeance",
"shortname" : "Vengeance",
"tcp" : {
"ip" : "127.0.0.1",
"port" : "9000",
"telnet" : "enable"
}
},
"zones" : {
"defaultstatus" : "0",
"ports" : {
"high" : "7400",
"low" : "7000"
}
}
}
}
Reply With Quote
  #4  
Old 02-09-2018, 08:17 PM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,475
Default

Public login still needs the 'legacy' flag, right?
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #5  
Old 02-09-2018, 08:37 PM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

I have no idea what that is... I can't connect via lan either cause the server doesn't show up in the server select list
Reply With Quote
  #6  
Old 02-09-2018, 09:03 PM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,475
Default

Check in the \backups folder of your server directory.

The old xml version of your config should be there and you can do a setting-by-setting comparison.
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #7  
Old 02-09-2018, 09:43 PM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

I did that already... it looks the same. Do I have to have a world server log in account or something like that now?
Reply With Quote
  #8  
Old 02-09-2018, 10:37 PM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,475
Default

Someone else posted a post-json issue that had to do with their login.ini `local_network` setting.


EDIT: I am just tossing things atm...
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #9  
Old 02-10-2018, 12:35 AM
Kingly_Krab's Avatar
Kingly_Krab
Developer
 
Join Date: May 2013
Location: United States
Posts: 1,500
Default

Your .JSON has this:
Code:
"host" : "localhost"
This is mine:
Code:
"host" : "127.0.0.1"
__________________
For Project 1999 related issues, check here.

Click here for the EQEmulator Wiki.
Reply With Quote
  #10  
Old 02-10-2018, 01:25 AM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,475
Default

Hmm...

Wonder if it's translating to the IPv6 address instead of the IPv4 one?
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #11  
Old 02-10-2018, 08:06 AM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

I've tried to change all localhost to 127.0.0.1 and still have the same result
Reply With Quote
  #12  
Old 02-10-2018, 08:44 AM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

Is there a way to revert back to my old server before the updates so that the players can still play on it until we figure this out?
Reply With Quote
  #13  
Old 02-10-2018, 04:02 PM
Akkadius's Avatar
Akkadius
Administrator
 
Join Date: Feb 2009
Location: MN
Posts: 1,956
Default

Under "loginserver1" which is your eqemulator loginserver entry, you need to make sure you specify the legacy flag, this is documented here:

https://github.com/EQEmu/Server/wiki...ig#loginserver

This was in the changelog and you can see an example of this in a config here:

https://github.com/Akkadius/EQEmuIns...onfig.json#L32

This legacy flag depicts a connection via the old netcode

Once you add that you should be good to go
__________________
Reply With Quote
  #14  
Old 02-10-2018, 07:41 PM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

That was it ... thanks guys it works now
Reply With Quote
  #15  
Old 02-10-2018, 07:47 PM
ionhsmith
Discordant
 
Join Date: Jun 2014
Posts: 280
Default

well I opened my mouth too soon. I can get to the character scree but the only one that can log in is my GM ... my other toons on another account goes to to disconnected screen
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:41 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3