EQEmulator Forums

EQEmulator Forums (http://www.eqemulator.org/forums/index.php)
-   General::News (http://www.eqemulator.org/forums/forumdisplay.php?f=594)
-   -   Linux Installers & Github Readme Updated & EQEmu Server Management Framework Overhaul (http://www.eqemulator.org/forums/showthread.php?t=40894)

Akkadius 09-12-2016 02:40 AM

Linux Installers & Github Readme Updated & EQEmu Server Management Framework Overhaul
Hello everyone.

Have quite a few different things to announce in a quick news post here. A lot of time has been put into these things.

We now have standardized installers for the following Linux Distributions:
  1. Ubuntu
  2. Debian
  3. Fedora
  4. CentOS

The install script can be found here:


Thanks N0ctrnl for assisting in getting some of these other platforms supported in the installer. Thanks to those in the coders channel that have assisted in testing installations in effort to make things simplified and easier to install/manage overall.

Github Read Me has been Updated

  • You will find that the Github Readme has had a few things added to it

Read up on the Massive EQEmu Server Management framework overhaul:
Post comments and questions below.

DanCanDo 09-12-2016 09:34 AM

I especially like the options of CLI arguments.
Thank you very much Akkadius, N0ctrnl (and others) for stuff like this. All that effort you
guys put in to development does not go unappreciated. :)

rhyotte 09-12-2016 11:32 PM

I can tell you for sure, This Rocks!

Thank You!!

jpyou127 09-13-2016 10:33 AM

Getting these error on the linux installer for debian 8:

"WARNING: The following packages cannot be authenticated"
"There are problems and -y was used without --force-yes"

I have a fresh Debian 8 install "putty" to the server and logged in as "root".

Running this command set:

"wget --no-check-certificate https://raw.githubusercontent.com/EQ...ler/install.sh -O install.sh && chmod 755 install.sh && ./install.sh"

Basically it stops because nothing can be installed.


N0ctrnl 09-13-2016 12:28 PM

Debian 8... what? If it's not 8.5 I don't think it's been tested.

Also, details details details. There's not much in what you've posted.

jpyou127 09-13-2016 01:36 PM

This errors on the install of packages.
A package is attempted as an install and it gives the first error: "WARNING: The following packages cannot be authenticated".
At the end of the attempt it gives this error: "There are problems and -y was used without --force-yes"


Akkadius 09-13-2016 01:53 PM

Make sure you have an Internet connection

N0ctrnl 09-13-2016 02:03 PM

Debian 8.5?

jpyou127 09-13-2016 02:09 PM

I have an internet connection as its a cloud hosted server, and I can ping google also.

And it does connect to run the initial script located at the URL above.

Debian 8 is the flavor thats offered. Here is an Error exactly as is repeated.

WARNING: The following packages cannot be authenticated!
libasan1 libatomic1 libcilkrts5 libisl10 libcloog-isl4 libgomp1 libitm1 liblsan0 libmpfr4 libquadmath0 libtsan0 libubsan0 libmpc3 binutils libc-dev-bin linux-libc-dev
libc6-dev cpp-4.9 cpp libgcc-4.9-dev gcc-4.9 gcc libstdc++-4.9-dev g++-4.9 g++ make libdpkg-perl dpkg-dev build-essential libfakeroot fakeroot libalgorithm-diff-perl
libalgorithm-diff-xs-perl libalgorithm-merge-perl libfile-fcntllock-perl manpages-dev
E: There are problems and -y was used without --force-yes


Akkadius 09-13-2016 02:10 PM


Originally Posted by jpyou127 (Post 251110)
I have an internet connection as its a cloud hosted server, and I can ping google also.

And it does connect to run the initial script located at the URL above.

Debian 8 is the flavor thats offered.


It's an issue related to the image they provide you then.


jpyou127 09-13-2016 02:11 PM

Roger that.


jpyou127 09-13-2016 02:16 PM

Ok I just ran apt-get update real quick to check and now its installing packages.

My apologies =)


N0ctrnl 09-13-2016 04:52 PM

Mileage could vary depending on the customization of the OS, as you've seen. Just remember - Details are the key. Specific errors, OS versions, etc.

Glad you're making progress :)

rudeboy88 09-15-2016 04:12 PM

Tried this today with a fresh minimal install of debian 8.5 on a vbox and it worked wonders with no fuss, thanks!

DanCanDo 09-23-2016 10:12 PM

I was curious about the current install stats shown on this page:
It shows 726 Windows (at the moment) and 59 Linux.
Are those stats based on the amount of installs from the installer script ?
If it is, that's a flabergasting number (chuckle)

Hao3w 11-18-2016 01:20 AM

Great!It's amazing!
Great!It's amazing!

rhyotte 03-23-2017 11:56 AM

Thanks again Akka!

Got bored and decided to fire up a CentOS 7.2 install. For some reason the wget Debian script works perfect, but the Fedora / Cent script using curb tanks with a cannot resolv error.

Now to get EoC up ;)

N0ctrnl 03-24-2017 08:58 AM

Cannot resolve is clearly an issue looking up one of the hosts it's trying to pull stuff from. Any idea which action was running when that error came up? That'll give us something to go on at least.

rhyotte 03-24-2017 03:11 PM

It was the initial start up of the script. I used the wget version instead, it worked perfect.

Thank you for the reply back. Much appreciated!

CentOS can be a bit of work to tame... After I got the server working nicely, I ended up getting annoyed at some other completely unrelated details that were fighting me and punted to Mint 18.1 cinnamon for a while. Nice and easy, with training wheels. ;) Will hit CentOS perhaps next version bump.

Akkadius 03-24-2017 03:12 PM

Debian is the way to go IMO, I run EZ and PEQ on it

rhyotte 03-24-2017 03:56 PM

Yeah, when Debian 9 is officially out I will use it. Debian is almost always solid, and reasonably easy. Not that there is anything at all wrong with 8...pretty solid actually!

rhyotte 03-31-2017 05:46 PM

So, Debian 9 now installs. I really do not have a dedicated box for just a server, so I also need to run wine for the client. Wine on Deb 9 is being a bit of a pain.

Fedora 25 most happily installs wine. It has a nice multilib setup. Debians multilib is incomplete. Heh...

I don't suppose you could poke and prod the install script for Fedora 25? PHP-MySql is deprecated as of Mariadb 7... It looks like there may also be a lua problem.

What I am trying to do is set up a server for a summer Learning & Play project. My daughter is interested in beginning to learn some of the nuts and bolts. What better way than to have a game she enjoys playing to mod on? :)

I will keep poking and prodding,

Thank you!

lanystvyl 07-31-2017 11:07 AM

set a server up over the weekend, everything is up and running, there was a few tricky spots but after familiarizing myself with Mariadb I got through it, and was able to level up a couple of characters to near 20th. Just an amazing job really.

I used an old IBM think-center ubuntu 16/32bit

All times are GMT -4. The time now is 10:51 AM.

Powered by vBulletin®, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.