Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Linux Servers

Support::Linux Servers Support forum for Linux EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-12-2020, 11:27 AM
kedra
Sarnak
 
Join Date: May 2007
Posts: 67
Default RoF2 crashing after scribing some spells

I'm trying to stand up a new server for testing and I'm experiencing a crash after scribing spells and zoning only when using the RoF2 client.

More info:

A fresh Titanium client works fine, I'm only having this problem with a RoF2 client I obtained. It was pre-configured for the EZ server but included files that could be extracted into the install directory for a PEQ server (which I've done).

This is a new linux install using Akkadius' linux install script. I've run the export script and placed the four resulting files on the client: spells_us.txt, dbstr_us.txt, SKillCaps.txt, BaseData.txt. The first two in the root install directory, the latter two in the 'Resources' directory (I think that's correct?)

Reproducing the problem is a little inconsistent but here's an example:

Level 50 shaman runs the command: #scribespells 50

The ROF2 client will crash when zoning and the player cannot log back in until wiping those spells (or maybe just an offending spell but I haven't figured out exactly which one) from character_spells.

Besides running the export script and installing those files into the client I also attempted to import the client files to repopulate spells and dbstr tables - same problem. I've reviewed spells_us.txt, counted columns and the client file and server table seem to be identical.

I've tested with other classes and confirmed it's not just a bogus shaman spell, most caster classes will crash after running #scribespell and scribing a (usually large) range of spells but it's not always after scribing the same range of spells.

I tried to identify exactly which spells were causing this behavior but it's inconsistent, for example, I executed the following series of commands and zoned between each:

Code:
Attempt 1
#scribespells 50 1   - crash (wipe character_spells table)

Attempt 2
#scribespells 50 50 - okay
#scribespells 50 49 - okay
#scribespells 50 40 - okay
#scribespells 20 1 - okay
#scribespells 30 20 - ok (thought I was in the clear here)
#scribespells 40 30 - crash (wipe character_spells table)

Attempt 3
#scribespells 40 30 - okay this time

I've enabled mysql logging but I didn't see anything obviously wrong, although maybe I'm just not sure what I'm looking for.

As I said, titanium client works fine and getting ROF2 working at this point is really just a curiosity about checking out the new client. I suspect the ROF2 client I obtained might be the problem but I'm just wondering if anyone has any troubleshooting tips. I've been out of eqemu for a *long* and I'm pretty rusty so I could be overlooking something obvious.

Thanks for any help,
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:19 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3