Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-30-2019, 01:48 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default Private Login Server

Upon fresh installation of new server, I am able to successfully create an account and login, once i log out and attempt to log back in it states username/password combo is not accurate, anyone have a solution?
Reply With Quote
  #2  
Old 10-30-2019, 02:59 PM
strugglegenerator
Hill Giant
 
Join Date: May 2012
Location: Riverhead, New York
Posts: 120
Default

If it's a truly private login server, you will be the only server listed at the server select screen.

If that's how you have it setup, in your login.ini file for the private server, change auto_create_accounts = TRUE. This will allow anyone who tries to login to your private server to type in a username/password at the account screen and it will save their username/password in the loginserver_server_accounts table in the database. However, the password will be encrypted and can never be changed (as far as I know). I usually leave auto_create_accounts = FALSE so nobody can just login to my private server and make endless accounts. I only enable it when a friend of mine wants to start playing on my server, and after he/she has made their desired accounts, I reset auto_create_accounts to FALSE.

This is completely different than if you were to login through the public EQEmulator login servers (where your server would be listed among all the other public servers) and you would have to go through the eqemulator.org registration process instead to create your usernames and passwords.
Reply With Quote
  #3  
Old 10-30-2019, 04:25 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

It is private, and only server listed, but I am able to create an account and login initially; create a character, fiddle around, but once I log out and attempt to log back in, then it gives me an error stating username/password are invalid, so to test I'll create a new account by typing in a different username and password and I'll be able to log in but once again once I log off it states username and password are invalid. I am using the new server set up where the login.ini was replaced with a .json file and Auto_Create_Accounts is set to true.

I attempted to go through the database but as you stated the passwords are encrypted and I don't know how to unencrypt,
Reply With Quote
  #4  
Old 10-30-2019, 06:02 PM
strugglegenerator
Hill Giant
 
Join Date: May 2012
Location: Riverhead, New York
Posts: 120
Default

If the player has already created an account on the server when it was still linked to the public EQEmulator login servers and they try to login on your new private login server, it will not let them in because it has a conflicting lsaaccount_id from the account table. You can resolve this by making sure the LoginServerID from the login_server_accounts table matches the lsaaccount_id column from the account table.
Reply With Quote
  #5  
Old 10-30-2019, 06:08 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

The loginserverid matches the lsaccount_id, the server was never made public
Reply With Quote
  #6  
Old 10-30-2019, 06:10 PM
strugglegenerator
Hill Giant
 
Join Date: May 2012
Location: Riverhead, New York
Posts: 120
Default

What do you have in the local_network = of your login.ini file?
Reply With Quote
  #7  
Old 10-30-2019, 06:15 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

I don't have a Login.ini, I have login.json
Reply With Quote
  #8  
Old 10-30-2019, 07:41 PM
strugglegenerator
Hill Giant
 
Join Date: May 2012
Location: Riverhead, New York
Posts: 120
Default

I have both a login.ini and an eqemu_config.json. You need both. I had to manually create mine.

Here is how I setup my files. The stuff in red needs to be changed:
eqemu_config.json
Code:
{
     "server" : {
          "chatserver" : {
               "host" : "",
               "port" : "7778"
          },
          "database" : {
               "db" : "peq",
               "host" : "localhost",
               "password" : "insertYourSQLDatabasePasswordHere",
               "port" : "3306",
               "username" : "root"
          },
          "mailserver" : {
               "host" : "",
               "port" : "7778"
          },
          "qsdatabase" : {
               "db" : "peq",
               "host" : "localhost",
               "password" : "eqemu",
               "port" : "3306",
               "username" : "insertYourSQLDatabasePasswordHere"
          },
          "webinterface" : {
               "port" : "9081"
          },
          "world" : {
			   "address" : "insertYourPublicIPAddressHere",
               "http" : {
                    "enabled" : "false",
                    "mimefile" : "mime.types",
                    "port" : "9080"
               },
               "key" : "thisHasAnAutoGeneratedKeyThatIDidNotCreate",
			   "localaddress" : "insertYourLocalIPAddressHere",
               "loginserver1" : {
                    "account" : "",
                    "host" : "insertYourLocalIPAddressHere",
                    "legacy" : "1",
                    "password" : "",
                    "port" : "5998"
               },
               "loginserver2" : {
                    "account" : "",
                    "host" : "InsertYourLocalIPAddressHere",
				    "legacy" : "0",
                    "password" : "",
                    "port" : "5998"
               },
               "longname" : "Your Server Name Here",
               "shortname" : "Your Server Name Here",
               "tcp" : {
                    "ip" : "InsertYourLocalIPAddressHere",
                    "port" : "9001"
               },
               "telnet" : {
                    "enabled" : "true",
                    "ip" : "0.0.0.0",
                    "port" : "9000"
               }
          },
          "zones" : {
               "defaultstatus" : "0",
               "ports" : {
                    "high" : "7400",
                    "low" : "7000"
               }
          }
     }
}
Then I also have a login.ini file that looks like this:
Code:
[database]
host = localhost
port = 3306
db = peq
user = root
password = InsertYourSQLDatabasePasswordHere
subsystem = MySQL

[options]
unregistered_allowed = TRUE
reject_duplicate_servers = FALSE
trace = TRUE
world_trace = FALSE
dump_packets_in = FALSE
dump_packets_out = FALSE
listen_port = 5998
local_network = insertPublicIPAddressHere
auto_create_accounts = TRUE

[security]
plugin = EQEmuAuthCrypto
mode = 5

[Titanium]
port = 5998
opcodes = login_opcodes.conf

[SoD]
port = 5999
opcodes = login_opcodes_sod.conf

[schema]
account_table = loginserver_server_accounts
world_registration_table = loginserver_world_server_registration
world_admin_registration_table = loginserver_server_admin_registration
world_server_type_table = loginserver_server_list_type
Make sure you run t_start_server_with_login_server and not t_start_server, since you are using the private login server.
Reply With Quote
  #9  
Old 10-30-2019, 07:53 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

The new server install removed the login.ini file and replaced it with login.json
Reply With Quote
  #10  
Old 10-30-2019, 07:56 PM
strugglegenerator
Hill Giant
 
Join Date: May 2012
Location: Riverhead, New York
Posts: 120
Default

Mine is from June 2019, so if it's changed since then, someone else is going to have to help you. This is just how mine is setup and it works.
Reply With Quote
  #11  
Old 10-30-2019, 09:52 PM
Huppy
Dragon
 
Join Date: Oct 2010
Location: Canada
Posts: 892
Default

The new loginserver schema, etc., were in place about Sept 16th.
__________________
Everyday I wake up with a whole new attitude ....
Reply With Quote
  #12  
Old 10-31-2019, 01:10 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

Is it possible that the Titanium Client is causing this issue?
Reply With Quote
  #13  
Old 10-31-2019, 06:28 PM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

I used the RoF2 client and the issue still persists, no matter how many accounts i create at the login screen, once i log off i can't re log back in, it only provides the error message;
Error - The username and/or password were not valid. Please check them and try again.

Any help on this would be much appreciated, i believe it is soley to do with the new loginserver update
Reply With Quote
  #14  
Old 11-05-2019, 07:49 PM
paleequinox
Fire Beetle
 
Join Date: Apr 2004
Posts: 18
Default

To get the local login server up and running again, you will need to modify the login.json file.

after the "world_trace" : false add a comma and hit return then add the line "local_network" : "192.168.86." with no comma.

Note use your own local network ip addressing in place of the 86 and don't forget the period after the 86

Hope this helps!
Reply With Quote
  #15  
Old 11-06-2019, 11:41 AM
cdolick24
Fire Beetle
 
Join Date: Sep 2018
Posts: 18
Default

Thank you for the response, I ended up deleting and reinstalling the server
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:14 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3