Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-01-2020, 01:39 AM
Draugr
Hill Giant
 
Join Date: Jan 2002
Posts: 138
Default New EQemu Server Install

Hi Everyone.

so, I got my EQemu server installed and running. I logged in and was able to play around for a bit. I then went to try creating a bot, but I get a message stating something along the lines that the bot name couldn't be verified or something similar to that. I've found info on that issue and while trying to follow the instructions to get bots working, I've stumbled upon this error message. I'm hoping someone here can help me.

"Enter a command #> check_bot_db_updates
[Database] Your server binaries (world/zone) are not compiled for bots..."

If that error is correct, why is the world/zone not compiled for bots? I used the zip file

https://eqemu.gitbook.io/server/cate...lation-windows

unzipped the file into my EQ folder on my server and then ran eqemu_install.bat as an admin. The process took a few minutes and then I got to the end where I can use the database, assets, and a few other commands. That is where the check_bot_db_updates command is run from and the result, is what is shown above.

Can anyone help me, please?

Thanks,
John
__________________
John Von Draugr
Reply With Quote
  #2  
Old 08-01-2020, 05:02 AM
Draugr
Hill Giant
 
Join Date: Jan 2002
Posts: 138
Default

I resolved the bots issue. Trial and error, but eventually I struck a pattern that seems to have gotten it working now.
__________________
John Von Draugr
Reply With Quote
  #3  
Old 08-01-2020, 04:22 PM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,785
Default

[For Ref:]

The default install of the server does not include BOTS support.

You will need to enter the command setup_bots from the eqemu_server.pl menu prompt.

This 'should' perform all necessary actions for operational bots.


If you decide to update your server binaries at some point in the future, you will need to go back into eqemu_server.pl and..

- Enter the assets sub-menu and type windows_server_latest_bots

then, either:

- Go back to main menu, enter the database sub-menu and check_bot_db_updates

..or..

- Start you server normally and let the automatic update process take care of it


Beyond that, there's always this forum and Discord
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #4  
Old 08-01-2020, 08:20 PM
Draugr
Hill Giant
 
Join Date: Jan 2002
Posts: 138
Default

Thanks Uleat for the response. Luckily I got it working, but I did want to mention in case it is important that I tried the setup_bots command and each time that line "Your server binaries (world/zone) are not compiled for bots..." came up.

It was late and I was tired so I don't remember exactly what I did, but it may have been something like running the add_windows_server_bots and when the zip file downloaded I quickly unzipped it before the script wiped it out. I then copied the world and zone.exe from that zip into the root EQemu folder. Then I ran setup_bots and I think that is when everything was fixed and the bot tables were finally in my database.

Again, thanks for the response. I'm glad to be back playing EQ as I miss it. I really miss the old days of EQ before Splitpaw was changed in 2000 or so, but after having problems with these classic EQ server setups, I decided to just use the latest EQemu & PEQ db and man am I glad I did. The Gloomingdeep zone and quests were an excellent starting point which would have been helpful during those dark old days of EQ's birth. LOL

Sorry for rambling on there.

Thanks Again.
John
__________________
John Von Draugr
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:20 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3