View Full Version : spell file db?
spider661
01-18-2009, 04:15 AM
i have updated my server awhile back to use the spell file from the db rather then the spell_us.txt so i am running alone and then i change a spell and WTF it never changed even after reset.. so i figure ok my spell file is still there maybe its reading it because its there so i remove it and spells dont work put it back and they work again so whats up i though it was default to read the db for spells now rather then the spell file what am i missing is there a setting i missed somewhere?
i have the spells_new table i have loaded my spells into it.
Secrets
01-18-2009, 05:53 AM
This is probably what you are missing, why it is a define rather than a rule, I may never know:
spdat.h:
//#define NEW_LoadSPDat
#define DB_LoadSPDat //load from DB vs spells_us.txt. for now, we're piggybacking NEW_LoadSPDat, so it will take precedence
spider661
01-18-2009, 06:02 AM
thats got to be it.. mine is commented the other way around
#define NEW_LoadSPDat
//#define DB_LoadSPDat //load from DB vs spells_us.txt. for now, we're piggybacking NEW_LoadSPDat, so it will take precedence
i left it alone because it said so it will take precedence guess they where wrong? will never know but ill give it a try thanks.
AndMetal
01-19-2009, 05:32 AM
why it is a define rather than a rule, I may never know
Basically, it's easier in the long run to use a define to just modify the functions than it is to completely redo them. That, and I don't really understand how to work with callbacks.
#define NEW_LoadSPDat
//#define DB_LoadSPDat //load from DB vs spells_us.txt. for now, we're piggybacking NEW_LoadSPDat, so it will take precedence
i left it alone because it said so it will take precedence guess they where wrong? will never know but ill give it a try thanks.
All that means is that, if both are #define'd, NEW_LoadSPDat will take precedence, so it will load from the spells_us.txt file.
nosfentora
03-05-2009, 05:07 PM
Just my $0.02 - from a naming convention and clarity standpoint, wouldn't it be better to name NEW_LoadSPDat 'File_LoadSPDat'?
NEW_LoadSPDat has a way of making it seem like that's the 'new' way to do things...
vBulletin® v3.8.11, Copyright ©2000-2025, vBulletin Solutions Inc.