Go Back   EQEmulator Home > EQEmulator Forums > Quests > Quests::Plugins & Mods

Quests::Plugins & Mods Completed plugins for public use as well as modifications.

Reply
 
Thread Tools Display Modes
  #1  
Old 11-26-2023, 02:13 PM
me678
Fire Beetle
 
Join Date: Nov 2023
Posts: 4
Default rathunt.pl

Hello,

I am currently running the EQemu built (11/22/2023) from the newest Linux installer on Debian. The server runs fine and local and remote players can join. However, I keep getting these errors relating to rathunt.pl:


Zone | QuestError | AddError Script Error | Package [qst_npc_999211] Event [EVENT_TIMER] Error [Perl runtime error: Undefined subroutine &plugin::LoadMysql called at ./plugins/rathunt.pl line 80.] -- [poknowledge] (The Plane of Knowledge) inst_id [0]
Zone | QuestError | AddError Script Error | Package [qst_npc_999209] Event [EVENT_TIMER] Error [Perl runtime error: Undefined subroutine &plugin::LoadMysql called at ./plugins/rathunt.pl line 35.] -- [poknowledge] (The Plane of Knowledge) inst_id [0]


When I check those lines they show the following code:

$dbh = plugin::LoadMysql();

Any ideas on how to fix the issue?

Thanks for your help!
Reply With Quote
  #2  
Old 11-26-2023, 07:22 PM
Kingly_Krab
Administrator
 
Join Date: May 2013
Location: United States
Posts: 1,590
Default

Are you missing this file?

MySQL.pl

if you have any further questions, concerns, or issues, feel free to join our Discord.

We have over 7 years worth of message back logs for issues similar to this.
Reply With Quote
  #3  
Old 11-26-2023, 08:16 PM
me678
Fire Beetle
 
Join Date: Nov 2023
Posts: 4
Default

Quote:
Originally Posted by Kingly_Krab View Post
Are you missing this file?

MySQL.pl

if you have any further questions, concerns, or issues, feel free to join our Discord.

We have over 7 years worth of message back logs for issues similar to this.
The file is present. I will join the Discord.
Reply With Quote
  #4  
Old 11-28-2023, 07:18 PM
me678
Fire Beetle
 
Join Date: Nov 2023
Posts: 4
Default

<deleted due to incorrect info> issue persists.

Last edited by me678; 11-28-2023 at 07:52 PM.. Reason: Wrong info
Reply With Quote
  #5  
Old 11-29-2023, 12:45 PM
me678
Fire Beetle
 
Join Date: Nov 2023
Posts: 4
Default Resolved

The solution was provided by Discord user Nameless[Bastion]. Thanks very much for your help!

Needed to ensure perl packages DBI and DBD were installed. DBD was missing, and after it was installed, everything worked perfectly.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

   

All times are GMT -4. The time now is 09:29 PM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3