Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2021, 11:23 AM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 180
Default Casting ILLUSION shows naked character

Casted " Illusion Gnome " on my Enchanter today and noticed afterwards that the character appeared naked. Everything was still equipped in inventory but I had to click off and on for each piece to show on the character.

Not sure when it started since it's been a while since I casted an Illusion spell. This was using the current Jun 19, 2021 build. Anyone else?
Reply With Quote
  #2  
Old 06-21-2021, 01:44 PM
Thalix's Avatar
Thalix
Sarnak
 
Join Date: Sep 2016
Posts: 91
Default

Quote:
Originally Posted by Zandig View Post
Casted " Illusion Gnome " on my Enchanter today and noticed afterwards that the character appeared naked. Everything was still equipped in inventory but I had to click off and on for each piece to show on the character.

Not sure when it started since it's been a while since I casted an Illusion spell. This was using the current Jun 19, 2021 build. Anyone else?
Hmm. It's working for me. RoF2 and latest Source.

No illusion:


Illusion Gnome:


You need to make sure that the items you wear can be equipped by gnomes.
Reply With Quote
  #3  
Old 06-21-2021, 03:12 PM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 180
Default

Thank you for the feedback Thalix.
I'm using RoF2 client as well with the latest bots source. The gear can be equipped as you referred too. I'm stumped as it worked in the past.

The only thing I can think of is that I sourced in " create_tables_content.sql " from the PEQ database archives about a week ago. I'll have to do more digging...
Reply With Quote
  #4  
Old 06-21-2021, 04:28 PM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 180
Default

Rolled back to a backup of the source I had (bin folder) which is dated: 05-20-2021 and the Illusion spell is working properly showing the equipment.

So definitely something happened in the source code between now and then, at least in the bots version...
Reply With Quote
  #5  
Old 06-21-2021, 06:38 PM
EQEmpires's Avatar
EQEmpires
Fire Beetle
 
Join Date: Mar 2021
Posts: 10
Default

Quote:
Originally Posted by Zandig View Post
Rolled back to a backup of the source I had (bin folder) which is dated: 05-20-2021 and the Illusion spell is working properly showing the equipment.

So definitely something happened in the source code between now and then, at least in the bots version...
Its probably due to the recent changes made to the appearance packet if I had to guess.
Reply With Quote
  #6  
Old 06-21-2021, 07:29 PM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 180
Default

It may be related to this....
https://github.com/EQEmu/Server/pull/1398

PS:
I'm using a High Elf Enchanter.
Reply With Quote
  #7  
Old 06-22-2021, 05:33 AM
Thalix's Avatar
Thalix
Sarnak
 
Join Date: Sep 2016
Posts: 91
Default

After more testing I was able to reproduce the error. I will create an issue for this.

https://github.com/EQEmu/Server/issues/1436
Reply With Quote
  #8  
Old 06-22-2021, 10:10 AM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 180
Default

Quote:
Originally Posted by Thalix View Post
After more testing I was able to reproduce the error. I will create an issue for this.

https://github.com/EQEmu/Server/issues/1436
Thank you for confirming the issue.
Reply With Quote
  #9  
Old 06-23-2021, 07:32 AM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 180
Default

This issue is now fixed by Akkadius:
https://github.com/EQEmu/Server/comm...3a18f2d6a71698

Just tested it out, and indeed it is now sorted.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:28 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3