Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::General Support

Support::General Support Post all topics here having to do with errors while trying to connect to an EQEMu server but not about the setup/running of the Server itself.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-04-2024, 08:00 PM
FinanceGuy
Fire Beetle
 
Join Date: Apr 2022
Posts: 3
Default Disconnecting to login screen upon zoning from fresh install of Spire

EDIT: My apologizes, realized I posted this in General Support instead of Windows Servers

Hey there, I've been troubleshooting this issue for some time and can't seem to find a forum post that's helping.

I'm using my own install of EQ with Spire.

Whenever I zone, I crash to the login screen. EQ does not say "You have been disconnected"

Here are the logs I see
Quote:
05-04-2024 19:51:36 | Zone | Info | Requesting world time
05-04-2024 19:51:36 | Zone | Info | World assigned Port [7001] for this zone
05-04-2024 19:51:36 | Zone | Info | [WorldServer::HandleMessage] Received Message SyncWorldTime
05-04-2024 19:51:36 | Zone | Info | Time Broadcast Packet: EQTime [04:42 pm]
05-04-2024 19:51:36 | Zone | Info | Websocket Server listener started on address [0.0.0.0] port [7001]
05-04-2024 19:51:36 | Zone | Info | Starting EQ Network server on port [7001]
05-04-2024 19:51:57 | Zone | Info | New connection from address [192.168.0.16] port [49656]
05-04-2024 19:51:58 | Zone | Info | New client from [192.168.0.16]:[49656]
05-04-2024 19:52:06 | Zone | Info | Attempting to route player to zone [fieldofbone] (7 version [0] long_name [The Field of Bone]
05-04-2024 19:52:06 | Zone | Info | Routed player to non-instance zone [fieldofbone] (7 version [0] long_name [The Field of Bone] notes []
05-04-2024 19:52:06 | Zone | Zoning | Client caught HandleZoneRoutingMiddleware [Dave] zone_id [78] instance_id [0] x [1845] y [-2980] z [11] heading [259] ignorerestrictions [0] zone_mode [4]
05-04-2024 19:52:06 | Zone | Info | Client [Dave] zone_id [78] instance_id [0] x [1845] y [-2980] z [11] heading [259] ignorerestrictions [0] zone_mode [4]
05-04-2024 19:52:06 | Zone | Zoning | Player [Dave] has requested zoning to zone_id [78] instance_id [0] x [1845] y [-2980] z [11] heading [259]
05-04-2024 19:52:06 | Zone | Zoning | Client [Dave] char_name [Dave] zoning to [fieldofbone] (7 instance_id [0] x [1845] y [-2980] z [11] zone_reason [11] success [0] zone_mode [ZoneSolicited] (4)
05-04-2024 19:52:06 | Zone | Info | Attempting to route player to zone [fieldofbone] (7 version [0] long_name [The Field of Bone]
05-04-2024 19:52:06 | Zone | Info | Routed player to non-instance zone [fieldofbone] (7 version [0] long_name [The Field of Bone] notes []
05-04-2024 19:52:06 | Zone | Zoning | Loaded zone flag []
05-04-2024 19:52:06 | Zone | Zoning | Checking zone request [fieldofbone] for expansion [9] (Dragons of Norrath) success [true]
05-04-2024 19:52:06 | Zone | Zoning | Client [Dave] char_name [Dave] zoning to [fieldofbone] (7 instance_id [0] x [1845] y [-2980] z [11] zone_reason [11] success [0]
05-04-2024 19:52:06 | Zone | Info | Reset to [1 Hour] from original remaining time [59 Minutes and 31 Seconds] duration [1 Hour] zone [PID (36496) The Plane of Knowledge (202)]
05-04-2024 19:52:06 | Zone | Zoning | ZoneToZone client [Dave] guild_id [4294967295] requested_zone [fieldofbone] requested_zone_id [78] requested_instance_id [0] current_zone [poknowledge] current_zone_id [202] current_instance_id [0] response [1] admin [255] ignorerestrictions [0]
05-04-2024 19:52:06 | Zone | Info | Dropping client: Process=false, ip=[192.168.0.16] port=[49656]
05-04-2024 19:52:06 | Zone | Info | Zone will go into an idle state after [60] seconds.
05-04-2024 19:52:06 | Zone | Zoning | ZoneToZone client [Dave] guild_id [4294967295] requested_zone [fieldofbone] requested_zone_id [78] requested_instance_id [0] current_zone [poknowledge] current_zone_id [202] current_instance_id [0] response [1] admin [255] ignorerestrictions [0]
Here are my config files

Quote:
eqemu_config.json
{
"server": {
"zones": {
"defaultstatus": "0",
"ports": {
"low": "7000",
"high": "7500"
}
},
"qsdatabase": {
"db": "peq",
"host": "localhost",
"port": "3306",
"username": "root",
"password": "eqemu"
},
"ucs": {
"host": "",
"port": "7778"
},
"world": {
"api": {
"enabled": false
},
"localaddress": "192.168.0.16",
"loginserver1": {
"port": "5998",
"account": "",
"password": "",
"host": "localhost"
},
"tcp": {
"ip": "0.0.0.0",
"port": "9001"
},
"telnet": {
"ip": "0.0.0.0",
"port": "9000",
"enabled": "true"
},
"key": "somelongrandomstring12345asdfffff",
"shortname": "localeq",
"longname": "Finance Guy's Local EQ Server"
},
"database": {
"db": "peq",
"host": "127.0.0.1",
"port": "3306",
"username": "eqemu",
"password": (deleted)
},
"files": {
"opcodes": "assets/opcodes/opcodes.conf",
"mail_opcodes": "assets/opcodes/mail_opcodes.conf"
},
"directories": {
"patches": "assets/patches/",
"opcodes": "assets/opcodes/"
}
},
"web-admin": {
"application": {
"key": "666e6bd5-3f23-43d5-8ca4-544d4689db83",
"admin": {
"password": "290511ae7fe68f3382f2cdc21f4233"
}
},
"launcher": {
"runSharedMemory": true,
"runLoginserver": true,
"runQueryServ": false,
"isRunning": true,
"minZoneProcesses": 10,
"staticZones": "poknowledge"
},
"quests": {
"hotReload": true
},
"serverCodePath": "/home/eqemu/code/"
},
"spire": {
"encryption_key": "bdc6450783dd6a2048364c8afcd9616ee7cc587ad20460337 7a7c93fb82728d5",
"http_port": 3007
}
}
login.json
Quote:
{
"database": {
"host": "127.0.0.1",
"port": "3306",
"db": "peq",
"user": "eqemu",
"password": (deleted)
},
"account": {
"auto_create_accounts": true
},
"worldservers": {
"unregistered_allowed": true,
"show_player_count": false,
"dev_test_servers_list_bottom": false,
"special_character_start_list_bottom": false,
"reject_duplicate_servers": false
},
"web_api": {
"enabled": true,
"port": 6000
},
"security": {
"mode": 14,
"allow_password_login": true,
"allow_token_login": true
},
"logging": {
"trace": false,
"world_trace": false,
"dump_packets_in": false,
"dump_packets_out": false
},
"client_configuration": {
"titanium_port": 5998,
"titanium_opcodes": "assets/opcodes/login_opcodes.conf",
"sod_port": 5999,
"sod_opcodes": "assets/opcodes/login_opcodes_sod.conf",
"display_expansions": true,
"max_expansions_mask": 524287
}
}
I did mess around a bit trying to get this to work, so the config files might be problematic.

I am connected to a modem/router, and I was boxing on one PC with multiple accounts - I get disconnected regardless of how I zone (zoneline, GM command, etc). This happens every time, but when I log back in, I am in the target zone, not the zone I attempted to leave from.

Thanks!
Reply With Quote
  #2  
Old 05-05-2024, 09:29 AM
FinanceGuy
Fire Beetle
 
Join Date: Apr 2022
Posts: 3
Default

Additional error found in EQ's dbg log
Quote:
[Sun May 05 09:23:36 2024]00278:Attempt to send message 18205 on a void connection.
[Sun May 05 09:23:36 2024]00279:Beginning EnterZone block.

[Sun May 05 09:23:36 2024]00280:Calling WorldAuthenticate. Countdown is 4

[Sun May 05 09:23:36 2024]00281:Networking: using port [64324].
[Sun May 05 09:23:36 2024]00282:Networking: Connection Established [1]
[Sun May 05 09:23:36 2024]00283:WorldAuthenticate: Initiating Login.
[Sun May 05 09:23:36 2024]00284:WorldAuthenticate. I got a message of type 0x7ceb (31979).
[Sun May 05 09:23:36 2024]00285:WorldRPServer message: server name localeq

[Sun May 05 09:23:36 2024]00286:WorldAuthenticate. I got a message of type 0x7499 (29849).
[Sun May 05 09:23:36 2024]00287:WorldAuthenticate. I got a message of type 0x578f (22415).
[Sun May 05 09:23:36 2024]00288:WorldAuthenticate. I got a message of type 0x6259 (25177).
[Sun May 05 09:23:36 2024]00289:WorldAuthenticate. Access granted.

[Sun May 05 09:23:36 2024]00290:World not ready, disconnected at C:\p4\EverQuest\live\EverQuest\EverQuest.cpp:21474

[Sun May 05 09:23:36 2024]00291:Networking: Connection Closed [0] with 0 pending bytes.
[Sun May 05 09:23:36 2024]00292:Cleanup 1

[Sun May 05 09:23:37 2024]00293:Cleanup 4

[Sun May 05 09:23:37 2024]00294:Cleanup 5

[Sun May 05 09:23:37 2024]00295:Cleanup 6

[Sun May 05 09:23:37 2024]00296:Cleanup 7

[Sun May 05 09:23:37 2024]00297:Cleanup 8

[Sun May 05 09:23:37 2024]00298:Cleanup 9

[Sun May 05 09:23:37 2024]00299:Cleanup 10
Reply With Quote
  #3  
Old 05-05-2024, 08:38 PM
FinanceGuy
Fire Beetle
 
Join Date: Apr 2022
Posts: 3
Default

This issue is resolved. I reinstalled from scratch which fixed everything.

It's possible I corrupted the database in an edit or something to do with a Spire config file.

Not exactly sure, but all is good.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

   

All times are GMT -4. The time now is 08:11 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3