Go Back   EQEmulator Home > EQEmulator Forums > Support > Support::Windows Servers

Support::Windows Servers Support forum for Windows EQEMu users.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-25-2020, 09:30 AM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 160
Default Spell sounds and Spell effects not working? Some info...

I recently set up a server again after many years.
Here are my findings regarding Spell sounds and Spell effects.

I've tested these clients as follows....

1) Underfoot - Spell sounds and Spell effects work fine when exporting ' spells_us.txt ' for the client using the symlink ' start_export_client_files '.

2) Rain of Fire 2 - Spell sounds and Spell effects will not work when exporting ' spells_us.txt ' for the client using the symlink ' start_export_client_files '.

The current ' spell_us.txt ' (as of 09/25/2020) has 41,377 entries. Anything over approximately 40,720 entries will cause the Spell sounds and effects not to work in the Rain of Fire 2 client.

Hope that helps.
Reply With Quote
  #2  
Old 09-25-2020, 10:20 AM
Huppy
Demi-God
 
Join Date: Oct 2010
Location: Canada
Posts: 1,019
Default

Quote:
Originally Posted by Zandig View Post

The current ' spell_us.txt ' (as of 09/25/2020) has 41,377 entries. Anything over approximately 40,720 entries will cause the Spell sounds and effects not to work in the Rain of Fire 2 client.

Hope that helps.
41,377 is the line entry number in the spells_us.txt. The actual spell ID's in the current file is 49,999

Tit: 9999
SoF: 15999
SoD: 23000
UF: 28000
RoF: 45000
Reply With Quote
  #3  
Old 09-25-2020, 11:57 AM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 160
Default

Thanks for the correction Huppy. I was too busy just looking at the line numbers in Notepad ++
Reply With Quote
  #4  
Old 09-25-2020, 03:32 PM
Uleat's Avatar
Uleat
Developer
 
Join Date: Apr 2012
Location: North Carolina
Posts: 2,810
Default

[Thanks to another Dev ~]

There is an allocated block of memory in the client that is shared by many systems.

When a system exceeds its expected 'use' size, other systems start to fail - spell sounds and effects tend to be the first to go.
__________________
Uleat of Bertoxxulous

Compilin' Dirty
Reply With Quote
  #5  
Old 09-25-2020, 07:36 PM
Zandig's Avatar
Zandig
Hill Giant
 
Join Date: Jun 2006
Location: New York City
Posts: 160
Default

Quote:
Originally Posted by Uleat View Post
[Thanks to another Dev ~]

There is an allocated block of memory in the client that is shared by many systems.

When a system exceeds its expected 'use' size, other systems start to fail - spell sounds and effects tend to be the first to go.

Excellent information Uleat. Much appreciated,
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:46 AM.


 

Everquest is a registered trademark of Daybreak Game Company LLC.
EQEmulator is not associated or affiliated in any way with Daybreak Game Company LLC.
Except where otherwise noted, this site is licensed under a Creative Commons License.
       
Powered by vBulletin®, Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Template by Bluepearl Design and vBulletin Templates - Ver3.3